Well-Known Member
Nov 6, 2011
cPanel Access Level
Root Administrator
I was alerted to one of the sites on our WHM server which uses PHP-FPM and runs PHP 7.2.
Some of the pages were showing 404 errors instead of the usual pages. I'm the only person who has access to the file system and I didn't make any changes. I diagnosed it as an issue with the order of RewriteRules in the main .htaccess file. Fixing the issue was just a case of changing the order of the RewriteRules but it was strange that I need to do this given that the site was working correctly yesterday.

The folder /opt/cpanel/ea-php72 was last changed today at 03:03 as part of the 74.0.9 update so it seems likely that an Apache or PHP-FPM update caused the issue (I have all Daily Updates set to automatic)

I was under the impression that the updating of the web server components (Apache and PHP-FPM) were handled solely by the user if/when the system was updated via EA4. Can anyone shed some light on exactly what parts of Apache and PHP-FPM get updated automatically?
I've had similar issues in the past with updates. I did check the 74.0.9 changelog but I'm not sure what I'm looking for really.

Which of the Update Preferences would need to be disabled in order to prevent this type of updating?



Get Proactive!
Apr 8, 2003
Chesapeake, VA
cPanel Access Level
DataCenter Provider
Because EA4 uses rpm based packaging for its distribution any time cpanel releases an update to it it's going to be installed as part of the daily upcp if you have automatic updates set.


Product Owner II
Staff member
Nov 14, 2017
Hi @monkey64

As indicated by @GOT PHP-FPM and Apache are both part of EA4 and as such when the daily update for cPanel runs the packages controlled by the EA4 repo will be updated. The issue you ran into is related to the thread here: SOLVED - [EA-7980] Rewrite rules broken after latest EA4 update Which should be resolved already.

Updates for EA4 run when /scripts/rpmup runs during cPanel's nightly maintenance. If you don't want to update automatically you'd need to go to update preferences and set updates to manual only. The caveat there is that you'd have to remember to update.