The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache build error: Invalid file type for 'tail_last_lines_of()

Discussion in 'EasyApache' started by Drowned, Jan 12, 2009.

  1. Drowned

    Drowned Member

    Joined:
    Dec 5, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    I'm trying to rebuild apache but I always get this error at the end... can't find anything about it. It happens at the end when it's testing everything. Anybody know what it means?

    Code:
    !! No SSL VirtualHost found skipping SSL test !!
    !! Test skipped ok !!
            -- End test 'Basic SSL Request for static content' --
            -- Begin test 'Multi SSL hits segfaults apache' --
    !! No SSL VirtualHost found skipping SSL test !!
    !! Test skipped ok !!
            -- End test 'Multi SSL hits segfaults apache' --
            -- Begin test 'Basic CGI-SYS Request .cgi' --
    !! The was no content. Please check that. !!
    !! Post check of 'httpd' process Ok !!
    -- End post apache restart tests --
    
    !! Invalid file type for 'tail_last_lines_of()' !!
    !! Restoring original working apache !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Restarting 'httpd' ... !!
    !! 'httpd' restart complete. !!
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Feel free to submit a support ticket at https://tickets.cpanel.net/submit/index.cgi?reqtype=tickets !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1231810743' !!
    
    :(
     
  2. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
    the same thing

    ! Invalid file type for 'tail_last_lines_of()' !!
    !! Restoring original working apache !!

    I am getting this error when building on cPanel 11.25.0-R42404 - WHM 11.25.0 - X 3.9 CENTOS 5.4.

    None of the built-in profiles can be built successfully. Already a few failure were submitted. Any idea what is going wrong?
    -------
    /var/cpanel/perl/easy/Cpanel/Easy/HttpdConf.pm was looking for /usr/local/apache/logs/suexec_log. Creating the file solved the problem
     
    #2 thobarn, Jan 26, 2010
    Last edited: Jan 26, 2010
  3. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    We are getting this as well, on 11.25.0-RELEASE_43473
     
Loading...

Share This Page