Apache build is failing after MySQL update

khav

Registered
Jul 11, 2014
3
0
1
cPanel Access Level
Website Owner
I had to upgrade to MySQL 5.5 to be able to update cpanel.Then i updated cpanel but when i run EasyApache every build is failing for an unknown reason.

Yum -y update is also not working properly


--> Finished Dependency Resolution
python26-PyYAML-3.08-4.el5.x86_64 from installed has depsolving problems
--> Missing Dependency: libyaml-0.so.1()(64bit) is needed by package python26-PyYAML-3.08-4.el5.x86_64 (installed)
clamav-0.98.4-1.el5.i386 from epel has depsolving problems
--> Missing Dependency: clamav-db = 0.98.4-1.el5 is needed by package clamav-0.98.4-1.el5.i386 (epel)
Error: Missing Dependency: libyaml-0.so.1()(64bit) is needed by package python26-PyYAML-3.08-4.el5.x86_64 (installed)
Error: Missing Dependency: clamav-db = 0.98.4-1.el5 is needed by package clamav-0.98.4-1.el5.i386 (epel)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
checkyum version 21.1
 

khav

Registered
Jul 11, 2014
3
0
1
cPanel Access Level
Website Owner
My webhost managed to bring site only . IPalias service was not started automatically after apache rebuild for some reason

- - - Updated - - -

i mean bring site online.....stupid typo
 

khav

Registered
Jul 11, 2014
3
0
1
cPanel Access Level
Website Owner
Can't update clamav due to some weird dependacy error

Hope someone can help me out ...been struggling with this for 1 hour

yum -y update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: mirrors.usc.edu
* epel: mirrors.solfo.com
* extras: repos.lax.quadranet.com
* rpmforge: mirror.hmc.edu
* updates: mirror.keystealth.org
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: clamav-db = 0.98.4-1.el5 for package: clamav
---> Package clamav-db.x86_64 0:0.98.4-1.el5.rf set to be updated
---> Package kernel.x86_64 0:2.6.18-371.9.1.el5 set to be installed
---> Package python26-jinja2.noarch 0:2.5.5-5.el5 set to be updated
--> Finished Dependency Resolution
clamav-0.98.4-1.el5.i386 from installed has depsolving problems
--> Missing Dependency: clamav-db = 0.98.4-1.el5 is needed by package clamav-0.98.4-1.el5.i386 (installed)
Error: Missing Dependency: clamav-db = 0.98.4-1.el5 is needed by package clamav-0.98.4-1.el5.i386 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello :)

The output shows that you are using the EPEL repo with YUM in the /etc/yum.repos.d directory. This is not standard. Are you using this repo for a specific package?

Also, please feel free to open a support ticket using the link in my signature if you want us to take a closer look. You can post the ticket number here so we can update this thread with the outcome.

Thank you.