shann

Well-Known Member
Jul 5, 2002
366
0
166
cPanel Access Level
Website Owner
I have compiled apache and works fine ,but when we complile we got these error messages.


Error Message:
Please run rhn_register (or up2date --register on Red Hat Enterprise Linux 3
or later)
as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation:
An error has occurred while processing your request. If this problem
persists please enter a bug report at bugzilla.redhat.com.
If you choose to submit the bug report, please be sure to include
details of what you were trying to do when this error occurred and
details on how to reproduce this problem.

Is it safe to register and update it?
 

web2corp

Member
Mar 28, 2006
11
0
151
Which operating system are you running? It sounds like it's either a copy of a Redhat Enterprise product or whitebox linux. If that's the case, Redhat is trying to get you to register your copy with them to log in to their repositories for updates. If you have a legit copy, registering shouldn't be a problem.

If that doesn't work, I would suggest looking into centos (http://www.centos.org) It is basically Redhat Enterprise Server 4 without the redhat (And therefore free). We run it on all of our production boxes here.