The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache configs everywhere....

Discussion in 'EasyApache' started by Unimatrix, Feb 28, 2010.

  1. Unimatrix

    Unimatrix Registered

    Joined:
    Feb 28, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    These are the cries of a desperate plea, I have a Centos 5.4 Server which has WHM/Cpanel.

    The basic config on te GUI is the directory for serving pages is /home.

    Now I have did a rebuild using easyapache a few times thinking that it could be different options security options not letting apache to run properly.

    The home directory is on 755 dont think it was that by default but changed it for the time being to rule it out.

    The httpd.conf so many of them I have identified the main conf using httpd -V and it shows that the main config file is conf/httpd.conf, which I traced to 2 places

    etc/httpd/conf
    /usr/local/apache/conf

    although I suspect they are the same files but when I do an ls -l they dont show up as a link or symlink.... anyhow I update 1 the other gets updated.

    both files show the website I had added via WHM Panel Create Account, and show the DocumentRoot to be set correctly to /home/accname/public_html

    yet when you point your browser to lets say http://serverip/~accountname/

    You see a Cpanel Blue 403 Screen then if you look in the error_log it reports the folder does not exisit in /usr/local/apache/htdocs/~accountname

    Very frustrating and very odd since by all accounts it should be working, having looked at the httpd.conf file I did notice that in DocumentRoot If I had removed the above path then the next instance would be used.

    i.e.

    <VirtualHost *>
    ...
    DocumentRoot /usr/local/apache/htdocs
    ...
    </VirtualHost>

    <VirtualHost 11.22.33.44:80>
    ...
    DocumentRoot /home/accountname/public_html/
    ...
    </VirtualHost>

    if I remove the above instance then the 2nd 1 is used for all other accounts as if it were global.

    Been searching on the net everywhere for an answer, and Im sure Im doing something really silly. But for the life of me cant figure it out.

    Any help appreciated.
     
  2. ChrisRHS

    ChrisRHS Well-Known Member

    Joined:
    Jul 12, 2006
    Messages:
    292
    Likes Received:
    5
    Trophy Points:
    18
    Do you have the "Apache mod_userdir Tweak" protection enabled? This would give you the 404 error. The setting is within:

    Main >> Security Center >> Apache mod_userdir Tweak

    Chris
     
  3. Unimatrix

    Unimatrix Registered

    Joined:
    Feb 28, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Genius

    Great thanks very much that was it, since im still on production server haven't linked domain names yet and as such now I understand what that option does.

    It just sounded good so I turned it on, should have read the message :)

    In future I will seek more help from the forums, I tend to not wont to bother anyone and as such always look for similar threads so I dont have to ask. And if I dont find a similar prob I tend no to ask. my bad.

    anyhow thanks very much
     
Loading...

Share This Page