Apache custom port not working properly

azadhussnain

Well-Known Member
May 28, 2020
52
0
6
India
cPanel Access Level
Root Administrator
hello guys,
i am have changed my apache port in WHM >> Tweak Settings.
Apache non-SSL IP/port = 0.0.0.0:7878
Apache SSL IP/port = 0.0.0.0:7424
and also allowed Port 7424 and 7878 in firewall.
port is pinging from my Wifi and Internet and Port is also pinging from servers but the servers where CSF Firewall is installed there not pinging.

i want to wget my hostname:7878 from another server. but on the another server CSF Firewall is installed, when i run wget myhostname:7878 then it shows connection refused. and when i disable csf then it's pinging correctly. tested this on 10+ servers, i ran wget myhostname:7878 on 10+ servers where csf is installed and all shows connection refused.

anyone have any solution
 
Last edited by a moderator:

andrew.n

Well-Known Member
Jun 9, 2020
631
182
43
EU
cPanel Access Level
Root Administrator
What does "netstat -ntpln" says? Does it shows that Apache is listening on that port?
 

sfriday02

Registered
Feb 17, 2021
4
2
3
Myrtle Beach
cPanel Access Level
Root Administrator
What does "netstat -ntpln" says? Does it shows that Apache is listening on that port?
Below is a very good description from Digital ocean...
you need to edit and add the ports you are using for webservices to the
/etc/csf/csf.conf file. It should take just a few seconds.



 
  • Like
Reactions: cPRex and andrew.n