The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache does not restart after account creation

Discussion in 'EasyApache' started by xisn, Jun 7, 2009.

  1. xisn

    xisn Well-Known Member

    Joined:
    Dec 4, 2004
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Has anyone else seen the issue of Apache not restarting after creating a new account? Everything else on the server seems fine it just will not restart.

    No log errors, no changes in the scripts... It just started happening a few days ago.

    Thanks!
     
  2. InstaCarma_Tech

    InstaCarma_Tech Well-Known Member

    Joined:
    Apr 22, 2009
    Messages:
    228
    Likes Received:
    1
    Trophy Points:
    18
    What happens when you try to restart apache? Does it give you any errors or does it remain stuck?
    If you do not get anything then try 'strace'

    Sometimes, your application/software would fail without giving you any errors. Neither would you find anything in the logs. ‘Strace’ might be of great help in such situations. It is not concerned with the configuration or the internals of the application. ‘Strace’ knows only about the syscalls (calls to the kernel).
    It is usually used with the options -f ( to follow the child processes) and -o (to save the output to a file)

    Code:
        root@server [~]# strace -f -o strace.txt /etc/rc.d/init.d/httpd start 
    The above command will try to start apache and save the output of the strace command in a file named strace.txt. By analysing this file, we can see the syscalls made and the processes being carried out. This will give us a clear idea of where the problem is occurring and what the error is which can be fixed accordingly.
     
  3. xisn

    xisn Well-Known Member

    Joined:
    Dec 4, 2004
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    The account becomes available when I restart Apache... It's like it does not complete the whole process when creating new accounts meaning, it gets everything done except for restarting Apache.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    What is your full cPanel version number?
     
  5. xisn

    xisn Well-Known Member

    Joined:
    Dec 4, 2004
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Sorry for the long delay Ken, I dropped the ball on this...

    It's only happening on one server and we have been avoiding placing new users on it.

    cPanel 11.24.5-R37629 - WHM 11.24.2 - X 3.9
    REDHAT Enterprise 4 x86_64 standard
     
  6. konrath

    konrath Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    367
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brasil
    Try removing the SSL shared. I had a similar problem.
     
    #6 konrath, Jul 29, 2009
    Last edited: Jul 29, 2009
  7. xisn

    xisn Well-Known Member

    Joined:
    Dec 4, 2004
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Not sure I understand what setting your referring to...?
     
  8. konrath

    konrath Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    367
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brasil
    You have the SSL instaled in your server? The shared SSL running in the main IP? Remove this shared SSL e try create the account again.
     
  9. konrath

    konrath Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    367
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brasil
    I have a server that had the same problem.

    SYMPTOMS
    The apache stop work when I create or delete an account.

    _________

    1) Remove the SHARED SSL

    The problem continues?

    2) Install the SHARED SSL again.
    3) Remove the SHARED SSL

    My problem is solved

    Note: I am unable to use the shared SSL on this server. :(
    The problem returns if I install the SSL shared again. :(

    Try.



    To remove the shared SSL

    1) Log in WHM
    2) GOTO in Manage SSL Hosts
    3) Verify the Installed SSL Hosts
    4) Remove the SHARED SSL running in YOUR MAIN IP ( SHARED SSL )

    If the problem continues. Install SSL again, and then remove.
     
    #9 konrath, Jul 29, 2009
    Last edited: Jul 29, 2009
  10. xisn

    xisn Well-Known Member

    Joined:
    Dec 4, 2004
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Ah, ok, I see what your referring to now... I do not have any shared SSL's on the main IP, all have their own IP's
     
  11. konrath

    konrath Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    367
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brasil
    Also check

    pico /etc/wwwacct.conf


    RESTARTAPACHE y <<<<============


    My config is

    ADDR 74.52.xxx.xxx
    CONTACTEMAIL abuse@myserver.xxx
    CONTACTPAGER
    DEFMOD x
    ETHDEV eth1
    FTPTYPE proftpd
    HOMEDIR /home
    HOMEMATCH home
    HOST server.myserver.xxx
    LOGSTYLE combined
    MINUID
    NS ns1.myserver.xxx
    NS2 ns2.myserver.xxx
    NS3 ns3.myserver.xxx
    NS4 ns4.myserver.xxx
    NSTTL 14400
    SCRIPTALIAS y
    TTL 14400
    RESTARTAPACHE y <<<========================
     
    #11 konrath, Jul 29, 2009
    Last edited: Jul 29, 2009
  12. xisn

    xisn Well-Known Member

    Joined:
    Dec 4, 2004
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator


    hhmm, seems I was missing that setting...
     
Loading...

Share This Page