The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache down when using options in httpd.conf

Discussion in 'EasyApache' started by arabgenius, Oct 11, 2013.

  1. arabgenius

    arabgenius Member

    Joined:
    Jun 25, 2011
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hello every body ...
    Am getting frequently hacked by symlink and cgi-shells nowadays

    and Iam using apache 2.0.64 and PHP 5.2.17 and ( works fine for me as my users cant stand php 5.3 yet )
    the problem is that before few months I was able to stop symlink and cgi-shells by using this in pre_virtualhost_global.conf
    Code:
    <Directory "/usr/local/apache/htdocs">
        Options -ExecCGI Includes -Indexes -FollowSymLinks +IncludesNOEXEC  -MultiViews +SymLinksIfOwnerMatch
        AllowOverride AuthConfig Indexes Limit FileInfo Options=IncludesNOEXEC,-Indexes,Includes,-MultiViews,SymLinksIfOwnerMatch,-FollowSymLinks
        Order allow,deny
        Allow from all
    </Directory>
    
    <Directory "/home">
        Options -ExecCGI Includes -Indexes -FollowSymLinks +IncludesNOEXEC  -MultiViews +SymLinksIfOwnerMatch
        AllowOverride AuthConfig Indexes Limit FileInfo Options=IncludesNOEXEC,-Indexes,Includes,-MultiViews,SymLinksIfOwnerMatch,-FollowSymLinks
        Order allow,deny
        Allow from all
    </Directory>
    but now I can't use the same code As it do not accept "Options="
    Code:
    Syntax error on line 19 of /usr/local/apache/conf/includes/pre_virtualhost_global.conf:
    Illegal override option Options=IncludesNOEXEC
    how to solve that ? and if not possible how to downgrade apache to the last version accept "Options="
     
    #1 arabgenius, Oct 11, 2013
    Last edited: Oct 11, 2013
  2. simonas

    simonas Well-Known Member

    Joined:
    Apr 21, 2013
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lithuania
    cPanel Access Level:
    Root Administrator
    Remove Options=IncludesNOEXEC
    From AllowOverride
     
  3. arabgenius

    arabgenius Member

    Joined:
    Jun 25, 2011
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    simonas did you read my post for real?
     
  4. arabgenius

    arabgenius Member

    Joined:
    Jun 25, 2011
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    I want to activate Options in AllowOverride
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I noticed you opened a support ticket for this issue. It was determined the best way to resolve this issue was to upgrade your version of Apache to version 2.2 or 2.4.

    Thank you.
     
Loading...

Share This Page