The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache errors

Discussion in 'EasyApache' started by alexandz, Dec 9, 2011.

  1. alexandz

    alexandz Well-Known Member

    Joined:
    Oct 28, 2011
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    cPanel Access Level:
    Root Administrator
    Hello! lately and had the following errors in my server with cpanel:

    [Fri Dec 09 04:04:40 2011] [notice] Graceful restart requested, doing restart
    [Fri Dec 09 04:04:40 2011] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Fri Dec 09 04:04:40 2011] [notice] SSL FIPS mode disabled
    [Fri Dec 09 04:04:40 2011] [notice] Apache/2.2.21 (Unix) mod_ssl/2.2.21 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 config
    ured -- resuming normal operations

    I know because it happens?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello alexandz,

    I believe this is the second time a thread has been started in Feature Requests area for a topic that is not a feature request. I already noted this on your other thread:

    http://forums.cpanel.net/f145/modify-php-ini-directives-246712.html#post1020562

    Please do not use the feature request forum for questions you happen to have. Please post them into the correct forum such as cPanel and WHM Discussions instead. This is where I have moved your existing post now.

    Next, what is the question you happen to have? Is it what is causing is error?

    Code:
    Bad file descriptor: apr_socket_accept
    If that is indeed your question, then what MPM are you using?

    Code:
    /usr/local/apache/bin/apachectl -M | grep -i mpm
    There are bugs noted for Apache using graceful restarts with the prefork MPM. You could switch to worker by recompiling Apache with EasyApache (WHM > EasyApache (Apache Update) or command line "/scripts/easyapache") if you are using suPHP, FCGI or CGI as the PHP handler.

    Thanks!
     
  3. alexandz

    alexandz Well-Known Member

    Joined:
    Oct 28, 2011
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    cPanel Access Level:
    Root Administrator
    Está pregunta no tiene ninguna relación con lo preguntado en:

    -link removed-

    Está pregunta la realice porque es un nuevo problema que surgió.

    Estoy usando suPHP
     
    #3 alexandz, Dec 12, 2011
    Last edited by a moderator: May 21, 2012
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    What MPM are you using? Please run the command indicated previously and let us know your MPM:

    Code:
    /usr/local/apache/bin/apachectl -M | grep -i mpm
    Also, the link you provided does not work.
     
  5. alexandz

    alexandz Well-Known Member

    Joined:
    Oct 28, 2011
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    cPanel Access Level:
    Root Administrator
    Default PHP Version (.php files) 5
    PHP 5 Handler suphp
    PHP 4 Handler none
    Apache suEXEC on

    As a result I got the following:
    mpm_prefork_module (static)

    Is that correct?
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    It is correct if it is using prefork and then what I also said initially applies here:

    Basically, I would suggest switching to MPM worker as you are using suPHP, since the error you've noted appears to occur when using MPM prefork + graceful restarts for Apache.
     
  7. sahostking

    sahostking Well-Known Member

    Joined:
    May 15, 2012
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Cape Town, South Africa
    cPanel Access Level:
    Root Administrator
    I've been reading up on Worker vs Prefork. Is worker still a better option seeing that a lot of posts say :

    Worker = Better Resource usage and is faster
    Prefork = Stability

    What are they trying to say? or is this not the case.

    I use suPHP, suhosin,suexec and prefork so has anyone got a similar setup hosting all types of PHP sites and have any issues, or is it really a better switch?

    Thanks
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    This thread isn't about which would be better, but about the error "Bad file descriptor: apr_socket_accept" occurring and what might be causing it to happen.
     
Loading...

Share This Page