Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

apache faild :(

Discussion in 'EasyApache' started by kaveh_cdeb, Feb 13, 2005.

  1. kaveh_cdeb

    kaveh_cdeb Active Member

    Joined:
    Oct 20, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    156
    hello

    i have this error :

    Syntax error on line 1417 of /usr/local/apache/conf/httpd.conf:
    RewriteMap: map file or program not found:/usr/local/cpanel/bin/leechprotect
    /etc/rc.d/init.d/httpd start: httpd could not be started

    i tried to build apache but still broken

    i also cant use pico command on ssh :-?

    how can i install it ?
    please help me to fix the apache :(
     
  2. BobFarkle

    BobFarkle Member

    Joined:
    Nov 19, 2002
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    If you don't have pico available you may have "nano" which is a pico clone.
    try from the command prompt:

    nano /usr/local/apache/conf/httpd.conf

    If that doesn't work then...

    Assuming you have rpm capabilities, you can get it from: http://www.nano-editor.org/dist/v1.2/RPMS/nano-1.2.4-1.i386.rpm

    simply

    wget http://www.nano-editor.org/dist/v1.2/RPMS/nano-1.2.4-1.i386.rpm
    rpm -ivh nano-1.2.4-1.i386.rpm

    Then you can use nano to edit the /usr/local/apache/conf/httpd.conf file and fix the file using the first command.
     
  3. BobFarkle

    BobFarkle Member

    Joined:
    Nov 19, 2002
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    Note that this bulletin board shortens the link so be sure to copy the shortcut instead of copying the text. Remove the space after the http:


    http: //www.nano-editor.org/dist/v1.2/RPMS/nano-1.2.4-1.i386.rpm
     
  4. kaveh_cdeb

    kaveh_cdeb Active Member

    Joined:
    Oct 20, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    156
    hello thanks for your help

    my server doing crazy things
    now i installed pico and then restart the server
    now i cant login to ssh
    and in the login said access denied
    su command dont work im sure i set the wheel goup user

    apache dont update , cpanel dont update too

    i think all connections with rhn disconnected. i chek reslove.conf but still broken :((
     
  5. kaveh_cdeb

    kaveh_cdeb Active Member

    Joined:
    Oct 20, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    156
    the users dont have permission to their folder on cpanel
    whats up on my server ? i reloaded the o/s just 2 day ago
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice