The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache failed after php4.3.9

Discussion in 'EasyApache' started by xml, Oct 13, 2004.

  1. xml

    xml Well-Known Member

    Joined:
    Jan 15, 2004
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    8
    did the update from WHM then apache failed

    then did ssh /scripts/easyapache ===> option1 ,still apache failed

    downgraded to php4.3.8 then apache worked fine

    how can i fix this problem ?

    note:
    WHM 9.9.0 cPanel 9.9.2-S8
    RedHat Enterprise 3 i686 - WHM X v3.1.0
     
    #1 xml, Oct 13, 2004
    Last edited: Oct 13, 2004
  2. blikhost

    blikhost Member

    Joined:
    Jul 9, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Miami Beach
    Hello xml,

    if your seeing apache failed in WHM after the php update..

    just restart it

    click on Restart HTTPD in WHM

    or

    service httpd restart from SSH


    if that still fails.just update apache again..


    If it fails again try this...

    /scripts/updatenow
    /scripts/upcp --force

    then recomplie apache..

    If it still fails you can try a couple other fixes listed in this thread at WHT:

    http://www.webhostingtalk.com/showt...rpage=15&highlight=apache failed&pagenumber=1


    Hope this helps! :)
     
  3. Mike2Own

    Mike2Own Active Member

    Joined:
    Apr 1, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    I'm willing to bet you're using turck mmcache.

    1) Remove the turck mmcache files
    2) Comment the lines in php.ini for turck ( use ; )
    3) Update php
    4) Recompile turck mmcache
    5) Uncomment the lines in php.ini
    6) Restart httpd

    :)
     
  4. xml

    xml Well-Known Member

    Joined:
    Jan 15, 2004
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    8
    yeah it was turck mmcache ,problem solved...thanks
     
  5. chican0

    chican0 Well-Known Member

    Joined:
    Mar 26, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Los Angeles

    Can you provide more detailed help/instructions? I had paid someone to install and configure my system with turck mmcache and have been unable to contact him. I tried updating apache but it fails. Now I am stuck with a broken build. I would appreciate the assistance.
     
  6. vietkool

    vietkool Active Member

    Joined:
    May 17, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    I am a newbie to the server here, my administrator on vacation, and I have server Apache failed every hour ... so I have to do something about this . I found some post here may help but don't know how to apply to it .. I have putty can acess to root. could you please step by step show me how to follow all the step above by using SSH ? I don't know much Linusx command so please bear with me .

    thaks
     
  7. Mike2Own

    Mike2Own Active Member

    Joined:
    Apr 1, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    I'm not sure what you do or don't know how to do specifically but I'll try to explain it a bit easier. This is what I did to get it to work... there may be easier ways of doing this, however. For what it's worth too it was done on two RedHat Enterprise machines.

    You're going to need to locate the directory that the turck mmcache files reside in. You can try using the command: locate mmcache

    Also you will need the path to your php.ini file so that you can edit it.

    Anything you need to type into your command line I will prefix with "command:" and wrap it in code tags so you can easily copy and paste.

    Okay here we go:

    We're going to remove the turck mmcache files from being used in your php.ini first.

    Step 1:

    Code:
    command: edit /your/path/to/php.ini 
    You should save a backup of the original before you make any changes. (Save it as phpini.bak or php.inibak, something easy to remember)

    You are going to search for the following line. I had installed it as a zend extension so this is what mine looked like.
    Code:
    zend_extension="/turck-mmcache-2.4.6/modules/mmcache.so"
    Be aware that the line is going to be dependant on your path to the turck source files. But it should be something similar that you can easily find.

    All we are going to do is add a ";" before the line which comments out the line so you can just uncomment it out later on. It should now look like this
    Code:
    ;zend_extension="/turck-mmcache-2.4.6/modules/mmcache.so"
    You are going to see lines near the one you just edited that start with mmcache. Do the same thing we just did for each of those lines, add a ;

    When that is done make sure you save it over the original php.ini.

    Step 2:

    Code:
    command: service httpd restart
    This will make sure the http server is restarted and not using any of the soon to be deleted turck files.

    Step 3:

    You will now need the path to your turck mmcache source directory for this. In my case my directory was turck-mmcache-2.4.6

    Do not do this if you do not know what you are doing. You could potentially wipe your system with the rm -rf command if it is done wrong.

    Code:
    command: rm -rf turck-mmcache-2.4.6
    Okay the source is deleted, the files are not referenced in the php.ini file, turck is gone. We can now recompile apache/php with the latest version.

    Step 4:

    Recompiling apache

    Code:
    command: /scripts/easyapache
    You may want to pick the option labeled "Load previous config" this way you do not lose anything you had already installed. When you are at the screen to pick the php version choose 4.3.9 and exit. PHP is now going to be upgraded.

    Step 5:

    Go back to step 1. Open your php.ini and remove the semi-colons we had just put in front of the mmcache entries, save it.

    Step 6:

    Download and recompile turck-mmcache

    Code:
    command: wget http://aleron.dl.sourceforge.net/sourceforge/turck-mmcache/turck-mmcache-2.4.6.tar.gz
    Code:
    command: tar xvzf turck-mmcache-2.4.6.tar.gz
    Code:
    command: cd turck-mmcache-2.4.6
    Code:
    command: export PHP_PREFIX="/usr/local"
    Code:
    command: $PHP_PREFIX/bin/phpize
    Code:
    command: ./configure --enable-mmcache=shared --with-php-config=$PHP_PREFIX/bin/php-config
    Code:
    command: make
    Code:
    command: make install
    Code:
    command: service httpd restart
    ...and we're done :) Hopefully that works for you guys. Again, this is what worked on the two machines I had turck installed on so theres no guarantees it will work with you but the other people in the thread seemed to have gotten it to work.
     
  8. asmar

    asmar Well-Known Member

    Joined:
    Jul 16, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    You can have MMcache installed without problem.
    I found a simple HOWTO and it works for my RedHat server.

    Url found it here:
    MMcache on RedHat
     
Loading...

Share This Page