The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache failed, but some sites are accessable?

Discussion in 'EasyApache' started by noimad1, Aug 8, 2005.

  1. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    I am having a strange problem here. If I go into ssh and restart apache, it says it restarts fine. If I try to restart it through WHM, it fails, and no matter what it always says failed in the server status.

    Here is the strange problem. Some of the sites on the server are working fine, and some are not comming up at all?

    If apache was failed, how can some sites come up?

    I check the error logs and there is nothing in there that stands out???

    How the heck can I get apache to restart?

    If i try the configtest it says everything checks out ok???
     
  2. flash7

    flash7 Well-Known Member

    Joined:
    Feb 16, 2004
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    service httpd restart
    service chkservd restart

    now check your "Service Status" in WHM

    That's all :)
     
  3. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    Sorry, I should have mentioned, that was one of the first items I tried. Of course it was to no avail.

    I did track down the problem just in case anyone cares. It turned out that we had logging turned on for mod_rewrite. And the log file grew to be over 2gb in size. So it was the culprit. It wasn't allowing apache to fully restart.

    After looking at the sites that were up verses the sites that were down, we were able to determine that it was only sites using mod_rewrite that were having problems.

    So we turned off the logging, deleted the large log, then restarted apache and everything was fixed.
     
Loading...

Share This Page