The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache failed @ Fri May 2 23:23:01 2003. A restart was attempted automagicly

Discussion in 'EasyApache' started by WeMasterz5, May 3, 2003.

  1. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    ok...I have searched all these forums and have read all the post and I can still not find out what to do to get the apache up and running on this new server

    running redhat 8.0 clean install

    where on earth do I start looking for the fix on this

    thanks all you great peoples :cool:
     
  2. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Pls be informative

    Hello,

    Past the error_log here. so that we can see why apache failed.

    tail /etc/httpd/logs/error_log or find the logs where apache failed and then paste it here.


    Regards,
     
  3. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    root@vanchau [/]# tail /etc/httpd/logs/error_log
    Failed loading /usr/local/Zend/lib/ZendOptimizer.so: /usr/local/Zend/lib/ZendOptimizer.so: cannot open shared object file: No such file or directory
    [Sat May 3 06:15:02 2003] [error] (2)No such file or directory: could not open transfer log file /usr/local/apache/domlogs/vanchau.#######.com.
    Failed loading /usr/local/Zend/lib/ZendOptimizer.so: /usr/local/Zend/lib/ZendOptimizer.so: cannot open shared object file: No such file or directory
    [Sat May 3 06:15:03 2003] [error] (2)No such file or directory: could not open transfer log file /usr/local/apache/domlogs/vanchau.########.com.
    Failed loading /usr/local/Zend/lib/ZendOptimizer.so: /usr/local/Zend/lib/ZendOptimizer.so: cannot open shared object file: No such file or directory
    [Sat May 3 06:23:26 2003] [error] (2)No such file or directory: could not open transfer log file /usr/local/apache/domlogs/vanchau.########.com.
    Failed loading /usr/local/Zend/lib/ZendOptimizer.so: /usr/local/Zend/lib/ZendOptimizer.so: cannot open shared object file: No such file or directory
    [Sat May 3 06:23:27 2003] [error] (2)No such file or directory: could not open transfer log file /usr/local/apache/domlogs/vanchau.#########.com.
    Failed loading /usr/local/Zend/lib/ZendOptimizer.so: /usr/local/Zend/lib/ZendOptimizer.so: cannot open shared object file: No such file or directory
    [Sat May 3 06:23:27 2003] [error] (2)No such file or directory: could not open transfer log file /usr/local/apache/domlogs/vanchau.#########.com.
     
  4. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Install Zendoptimizer

    Hello,

    You haven't installed the Zend Engine v2.1.0 that is required for php files.

    goto /scripts/installzendopt and follow the Steps..

    if not just make a serach on this forum somebody has put down the steps for doing it.

    Hope this helps!!

    Regards,
    :cool:
     
  5. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    ok...tried doing the zend both ways and no go

    I pico the error log and see this

    [Fri May 2 12:45:00 2003] [error] [client 127.0.0.1] File does not exist: /usr/local/apache/htdocs/whm-server-s$
    [Fri May 2 12:50:00 2003] [error] [client 127.0.0.1] File does not exist: /usr/local/apache/htdocs/whm-server-s$
    [Fri May 2 12:55:01 2003] [error] [client 127.0.0.1] File does not exist: /usr/local/apache/htdocs/whm-server-s$
    [Fri May 2 15:08:27 2003] [notice] SIGUSR1 received. Doing graceful restart
    [Fri May 2 15:08:27 2003] [error] (2)No such file or directory: could not open transfer log file /usr/local/apa$
     
  6. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    ok...the zend issue fixed but still no apache

    at the tail of the error log is this now

    [Sat May 3 07:22:41 2003] [error] (2)No such file or directory: could not open transfer log file /usr/local/apache/domlogs/vanchau.#######.com



    :(
     
    #6 WeMasterz5, May 3, 2003
    Last edited: May 3, 2003
  7. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    anyone ?? I have tried everything that I can think of, all the diff updates, diff versions, checked all the .conf files recomplied apache many times, used easyapache countless times with diff settings...etc,etc,etc

    but still no apache running :(
     
  8. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    I don't know if this will help or not, but it's worth a try. What do you get when you do:

    /usr/local/apache/bin/httpd -t
     
  9. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    root@vanchau [/]# /usr/local/apache/bin/httpd -
    Warning: User directive in <VirtualHost> requires SUEXEC wrapper.
    Warning: Group directive in <VirtualHost> requires SUEXEC wrapper.
    Warning: User directive in <VirtualHost> requires SUEXEC wrapper.
    Warning: Group directive in <VirtualHost> requires SUEXEC wrapper.
    root@vanchau [/]#
     
  10. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    after enabling it from WHM and running that I see it as

    root@vanchau [/]# /usr/local/apache/bin/httpd -t
    Syntax OK
    root@vanchau [/]#

    but still no apache
     
  11. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    The problem is not with compiling apache. The problem is you have an issue when apache tries to open the transfer log for one site, as noted in the error:

    [Sat May 3 06:15:02 2003] [error] (2)No such file or directory: could not open transfer log file /usr/local/apache/domlogs/vanchau.#######.com.

    Does vanchau.#######.com exist as an account on the machine? Is it a user account? Is the hostname? If it is valid:

    touch /usr/local/apache/domlogs/vanchau.#######.com
    chmod 644 /usr/local/apache/domlogs/vanchau.#######.com

    (Replacing the XX as approriate, of course.)

    If it isn't a real account, edit your httpd.conf and comment out/remove the entry for it.

    Either way, restart apache and all should be fine.
     
  12. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    I see no domlogs directory

    the accounts are real accounts on the server

    <VirtualHost ***.**.***.**>
    ServerAlias www.########.com ########.com
    ServerAdmin webmaster@########.com
    DocumentRoot /home/sites/########/public_html
    User ########
    Group ########
    ServerName www.########.com
    CustomLog domlogs/########.com combined
    ScriptAlias /cgi-bin/ /home/sites/########/public_html/cgi-bin/
    </VirtualHost>


    <VirtualHost ***.**.***.**>
    ServerAlias www.vanchau.########.com vanchau.########.com
    ServerAdmin webmaster@vanchau.########.com
    DocumentRoot /home/sites/vanchau/public_html
    User vanchau
    Group vanchau
    ServerName www.vanchau.########.com
    CustomLog domlogs/vanchau.########.com combined
    ScriptAlias /cgi-bin/ /home/sites/vanchau/public_html/cgi-bin/
    </VirtualHost>
     
  13. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    mm...logged into the WHM just now and got the popup for

    Hostname A Entry Missing!

    The server was unable to lookup an an A entry for its hostname (vanchau.########.com). This is generally because the entry was never added. However this could also be the result of your nameserver(s) being down. If you would like to attempt to automaticlly add the entry,



    when I try to do this it gives me a conn error
     
  14. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    CustomLog domlogs/vanchau.########.com combined

    Did you look in /usr/local/apache/domlogs for vanchau.########.com? Does it exist? If not, that's your problem, and you need to create that file as noted above. The server having an A record or not has no bearing on getting apache to start.
     
  15. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    well I will be fried beyound fried

    that was it...missing the dir

    thanks so very much
     
Loading...

Share This Page