The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache failed. Please help if can

Discussion in 'EasyApache' started by DWHS.net, Jun 26, 2003.

  1. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Hello,

    Here is the error:

    Syntax error on line 209 of /usr/local/apache/conf/httpd.conf:
    Cannot load /usr/local/apache/libexec/libphp4.so into server: /lib/libc.so.6: version `GLIBC_2.3.2' not found (required by /usr/X11R6/lib/lib$

    I sappose i can comment out the messed up mod, but to fix i am going to try /easyapache in hopes that it will re-install the mod correctly.

    Any thoughts are much appreciated.

    -Charles

    cPanel.net Support Ticket Number:
     
  2. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    let us know if that worked.

    cPanel.net Support Ticket Number:
     
  3. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    /easyapache didn't work since php wants to access a library that is not on the server.

    For now we commented out all the mods in apache untill we can safely recompile apache with php.

    The wierd part is it happended out of the blue.

    I will post the results here just in case some else enters the twilight zone with us.

    -Charles

    cPanel.net Support Ticket Number:
     
  4. hkewell

    hkewell Well-Known Member

    Joined:
    May 17, 2002
    Messages:
    170
    Likes Received:
    0
    Trophy Points:
    0
    me too. Before problem, I just try /scripts/upcp and then update some.

    Please fix /scripts/upcp !

    Thanks

    cPanel.net Support Ticket Number:
     
  5. SoHo

    SoHo Active Member

    Joined:
    May 7, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    same problem... apache don't work before software update on CPanel

    cPanel.net Support Ticket Number:
     
  6. SageBrian

    SageBrian Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    415
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    NY/CT (US)
    cPanel Access Level:
    Root Administrator
    yup...

    right out of nowhere

    cPanel.net Support Ticket Number:
     
  7. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
  8. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    When doing reinstall of glibc i get this:

    Retrieving http://updates.cpanel.net//redhat/updates/8.0/en/os/i386/glibc-2.3.2-4.80.6.i386.rpm
    Preparing... ##################################################
    glibc warning: /etc/nsswitch.conf created as /etc/nsswitch.conf.rpmnew
    ##################################################
    Stopping sshd:[ OK ]
    sleep: /lib/i686/libpthread.so.0: version `GLIBC_2.3.2' not found (required by /lib/librt.so.1)
    sleep: /lib/i686/libc.so.6: version `GLIBC_2.3.2' not found (required by /lib/librt.so.1)
    Starting sshd:[ OK ]
    Install Complete

    cPanel.net Support Ticket Number:
     
  9. Sopos

    Sopos Well-Known Member

    Joined:
    Nov 16, 2001
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    The problem is on the LibX11, so on the GD Library.
    If you use easyapache with options 2 it works (eventually kill apache after easyapache and restart).
    The problem is that you haven't gd library (but apache & php works).

    I have the problem on 2 server on 10 and the red hat is the same (and cpanel version is the same).

    cPanel.net Support Ticket Number:
     
  10. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    I solved it!

    WHM - Software - Install an RPM

    Reinstall:

    glib2
    glib
    glib-common

    Make sure you select both "Ignore Dependicies" and "Force Install (required if reinstalling a package)"

    I already tried this before in another order (first common, then glib) but that didn't work out so I guess the order is of some importance.

    I also first upgraded to Edge version, that may be the reason too.

    Any questions are welcome.
     
    #10 NNNils, Jun 27, 2003
    Last edited: Jun 27, 2003
  11. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Man.. wish I would of thought about that. We ended up re-compiling our Kernel to a updated version to fix it. Your way would of saved some serious labor.

    Good work,

    cPanel.net Support Ticket Number:
     
  12. SoHo

    SoHo Active Member

    Joined:
    May 7, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    warning: /var/tmp/rpm-xfer.A2bBQd: V3 DSA signature: NOKEY, key ID db42a60e
    Retrieving http://updates.cpanel.net//redhat/updates/8.0/en/os/i386/glibc-2.3.2-4.80.6.i386.rpm
    Preparing... ##################################################
    glibc warning: /etc/nsswitch.conf created as /etc/nsswitch.conf.rpmnew
    ##################################################
    Stopping sshd:[ OK ]
    sleep: /lib/i686/libpthread.so.0: version `GLIBC_2.3.2' not found (required by /lib/librt.so.1)
    sleep: /lib/i686/libc.so.6: version `GLIBC_2.3.2' not found (required by /lib/librt.so.1)
    Starting sshd:[ OK ]

    cPanel.net Support Ticket Number:
     
  13. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16

    Waht do you want to say with this?

    cPanel.net Support Ticket Number:
     
  14. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Another apache failed out of no where.

    I tried to reboot apache and got this:

    Waiting for httpd to restart.... . . . . . . . . . . finished.

    httpd status

    Can't connect at /scripts/restartsrv line 215, line 71439.

    I am going to look at the error logs.

    Two servers in two days, what's going on... :mad:

    -Charles

    cPanel.net Support Ticket Number:
     
  15. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Should of known,

    Syntax error on line 204 of /usr/local/apache/conf/httpd.conf:
    Cannot load /usr/local/apache/libexec/libphp4.so into server: /lib/libc.so.6: version `GLIBC_2.3.2' n$

    Cpanel please take care of the problem, this is unacceptable.

    -Charles

    cPanel.net Support Ticket Number:
     
  16. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    glib-common won't update it shows a blank screen, apache is still down.

    Anyhting else.... anyone

    cPanel.net Support Ticket Number:
     
  17. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    I also rebooted a couple of times between operations, maybe that did the trick?
     
  18. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Did you upgrade to edge first or did you re-install the rpm's first?

    Thanks by the way for the posts, I am surprised this isn't a bigger issue. I must be missing something, Charles

    cPanel.net Support Ticket Number:
     
    #18 DWHS.net, Jun 27, 2003
    Last edited: Jun 27, 2003
  19. pingo

    pingo Well-Known Member

    Joined:
    Nov 16, 2002
    Messages:
    430
    Likes Received:
    0
    Trophy Points:
    16
    So what is this! - is this cPanel related? - Then please take care as this is how we loose customers. Such things shouldn't happen when using the "stable" version. :(

    Thanks
    John

    cPanel.net Support Ticket Number:
     
  20. andyf

    andyf Well-Known Member

    Joined:
    Jan 7, 2002
    Messages:
    246
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    Code:
    wget ftp://fr.rpmfind.net/linux/redhat/8.0/en/os/i386/RedHat/RPMS/XFree86-libs-4.2.0-72.i386.rpm ; rpm -U --force --nodeps XFree86-libs-4.2.0-72.i386.rpm
    that will work (please use your local rpmfind mirror). but it'll break again tonight when upcp runs.

    it seems like the XFree86 libs installed by upcp were compiled using glibc 2.3.2, which hey-ho isn't standard on RH8, so it's just bust loads and loads of things.

    rolling back the libs (as above) will work - until the next update.

    either RH have made a big balls-up or cpanel have put the wrong update up for RH8, not sure which.

    goal

    cPanel.net Support Ticket Number:
     
    #20 andyf, Jun 27, 2003
    Last edited: Jun 27, 2003
Loading...

Share This Page