The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache failed

Discussion in 'EasyApache' started by uv3net, Apr 18, 2003.

  1. uv3net

    uv3net Member

    Joined:
    Apr 7, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    Hello,

    I receive this message every 15 minutes since 3 day.

    What can i do?

    Thanks for your help!

    apache failed @ Fri Apr 18 13:13:41 2003. A restart was attempted automagicly.
     
  2. Nico

    Nico Well-Known Member

    Joined:
    Dec 5, 2001
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Edmond, OK
    You might check /usr/local/apache/logs/etror_log for clues. We had the same problem and it was due to FD_SETSIZE configuration. You might grep your error log for that to check if you have that problem.
     
  3. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    I have the same problem, "apache failed @ Sat May 31 15:47:58 2003. A restart was attempted automagicly."

    The errorlog states the following:

    [Sat May 31 15:47:44 2003] [warn] [csd] filedescriptor (1027) larger than FD_SETSIZE (1024) found, you probably need to rebuild Apache with a larger FD_SETSIZE
    [Sat May 31 15:47:45 2003] [warn] [csd] filedescriptor (1027) larger than FD_SETSIZE (1024) found, you probably need to rebuild Apache with a larger FD_SETSIZE
    [Sat May 31 15:47:45 2003] [warn] [csd] filedescriptor (1027) larger than FD_SETSIZE (1024) found, you probably need to rebuild Apache with a larger FD_SETSIZE

    and so on...

    Nico, could you please tell me how to reset the FD_SETSIZE?
    sounds like the same problem you experienced.

    And at the end the log says:
    [Sat May 31 15:47:58 2003] [notice] caught SIGTERM, shutting down
    Zend Optimizer requires Zend Engine API version 20020429.
    The Zend Engine API version 20021010 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.

    Zend Optimizer requires Zend Engine API version 20020429.
    The Zend Engine API version 20021010 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.

    Zend Optimizer requires Zend Engine API version 20020429.
    The Zend Engine API version 20021010 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.

    [Sat May 31 15:48:03 2003] [notice] Apache/1.3.27 (Unix) mod_jk/1.2.0 mod_log_bytes/1.2 mod_bwlimited/1.0 PHP/4.3.1 FrontPage/5.0.2.2510 mod_ssl/2.8.12 OpenSSL/0.9.6b configured -- resuming normal operations
    [Sat May 31 15:48:03 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Sat May 31 15:48:03 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Sat May 31 15:48:04 2003] [crit] (98)Address already in use: make_sock: could not bind to port 443


    Does anybody know what the last part means?

    Thanks a lot for your help!

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  4. Manu

    Manu Member

    Joined:
    Nov 21, 2001
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    From a SSH console logged in as root

    /scripts/easyapache - and select option 6 to raise the FD_SETSIZE limit. ( making sure to go throu anything you need extra added althou a default config should do it )

    cPanel.net Support Ticket Number:
     
    #4 Manu, May 31, 2003
    Last edited: May 31, 2003
  5. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    Thanks Manu, I ran easyapache as suggested, but the error keeps showing up.

    anyone know a way to verify wheater the changes were actually made?

    cPanel.net Support Ticket Number:
     
  6. swiss_toni

    swiss_toni Member

    Joined:
    Jun 19, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I am having a similar problem with apache, bind and mysql.

    Here is a snippet from my error_log for apache around the time I received the "apache failed @ Fri Jun 20 17:37:49 2003. A restart was attempted automagicly." message.

    Looks like SSL port problems to me, but someone hopefully can point me in the right direction???
     
    #6 swiss_toni, Jun 20, 2003
    Last edited: Jun 20, 2003
  7. LS_Drew

    LS_Drew Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    187
    Likes Received:
    0
    Trophy Points:
    16
    I'm having this same problem with the SSL.

    Crashes every time anyone deletes an account now. Before I changed to stable, it was doing it every time one was created.

    cPanel.net Support Ticket Number:
     
  8. swiss_toni

    swiss_toni Member

    Joined:
    Jun 19, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    LS_Drew...what version of cPanel do you have? and are you hosting with rackshack?

    cPanel.net Support Ticket Number:
     
  9. LS_Drew

    LS_Drew Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    187
    Likes Received:
    0
    Trophy Points:
    16
    No, not with rackshack

    WHM 7.2.0 cPanel 7.2.1-S67

    I downgraded from the damn Release version that they put you on when you first install. (HINT!!! Nick, it's not too bright to put people on unstable Cpanel when they first install it!!!!)

    cPanel.net Support Ticket Number:
     
  10. LS_Drew

    LS_Drew Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    187
    Likes Received:
    0
    Trophy Points:
    16
    btw...toni, it's still doing this. And this is terrible. Every time an account is created, apache crashes.

    I've got a cron going every minute to restart it, but that's no way to live...

    cPanel.net Support Ticket Number:
     
  11. LS_Drew

    LS_Drew Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    187
    Likes Received:
    0
    Trophy Points:
    16
    still busted...this really sucks

    cPanel.net Support Ticket Number:
     
  12. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    Looks like something is bound to port 443 instead of ssl. Check netstat -anp | grep 443 to get the process id. Then use killall -p id# to kill that process. Then use /etc/rc.d/init.d/https start to start apache. Now check the logs as well as /var/log/messages to make sure everything is ok.

    cPanel.net Support Ticket Number:
     
  13. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    Send us over a support ticket and we will go in and fix things for you.

    cPanel.net Support Ticket Number:
     
  14. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    I get this:

    [Wed Jan 7 20:48:25 2004] [warn] NameVirtualHost 66.135.33.201:80 has no VirtualHosts

    It is directly related to this thread, thats why I post it here, please help!
     
  15. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    I know this is an old discussion but i have a server running R5 doing the exact smae thing.

    ive done as suggested here and 443 shows:

    so ive killed 9153 and restarted apache but still nothing...

    any one have any ideas?
     
  16. iko

    iko Well-Known Member
    PartnerNOC

    Joined:
    Jan 29, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Same problem here. Raise FD_SETSIZE doesn't work. Although I compiled apache with the option above Apache keeps on failing because it cannot open so many files. I opened a ticket with cPanel support regarding this.
     
  17. katz_global

    katz_global Well-Known Member
    PartnerNOC

    Joined:
    Oct 18, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hosting from: Panama, Hong Kong, Singapore, Malays
    for what its worth I had this problem and found:

    found: tail -50 /usr/local/apache/logs/error_log

    [Fri Sep 10 11:57:56 2004] [crit] (98)Address already in use: make_sock: could not bind to port 443

    apache was not starting because rinetd was bound to port 443.

    cleared the rinetd conf file /etc/rindtd.conf and killed the pids and rebooted the server and it cleared up.

    I don't know if that is your issue but for anyone else this is one thing that can keep apache down although this was a server we got back from a client and we did not realize rinetd was running at first.
     
Loading...

Share This Page