The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache fails after rebuild with Curl

Discussion in 'EasyApache' started by mschulz, Jul 14, 2005.

  1. mschulz

    mschulz Member

    Joined:
    Mar 4, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I'm trying to build apache with php 4.3.11 and Curl, among other options. It fails upon trying to start. I have attached the verbose output of the easyapache build results in a text file. Any help would be greatly appreciated. Thank you all in advance!
     

    Attached Files:

  2. mschulz

    mschulz Member

    Joined:
    Mar 4, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Update: Building with either Curl or Curl SSL works, but not both. I require both for my billing system. Perhaps that bit of information will prove helpful.
     
  3. Sinewy

    Sinewy Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    Ticking only curl SSL will not work because curl itself is not selected. You will need to select curl, then curl SSL on top.

    If you would like me to look at your server, contact me by any of the methods in my profile.

    No need to pay me.

    Regards,
    Alan
     
  4. mschulz

    mschulz Member

    Joined:
    Mar 4, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    So you're saying I need to compile with Curl, then with Curl SSL?
     
  5. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    I have also had this issue for a few months... I think it started when php 4.3.11 came out.

    I just tried rebuilding php 4.4.0 with just Curl (no curl ssl) and I still get an error with it...

    Code:
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 590 (offset 45 lines).
    Hunk #2 succeeded at 904 (offset 19 lines).
    configure php-4.4.0...(--with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --with-curl --enable-exif --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-gettext --with-imap --with-imap-ssl --with-kerberos --with-mcrypt --with-mhash --enable-magic-quotes --with-mysql=/usr --with-openssl --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --enable-versioning --with-xmlrpc --with-zlib).........................................................Done
    make -j 1 php-4.4.0...(clean)....Done
    make -j 1 php-4.4.0..........................................................................................................................................................................................................................................Done
    make: *** [libphp4.la] Error 1
    make php-4.4.0...(install)..........Done
    make: *** [libphp4.la] Error 1
    [Sun Jul 17 09:20:46 2005] [warn] module mod_ssl.c is already added, skipping
    [Sun Jul 17 09:20:46 2005] [warn] module mod_php4.c is already added, skipping
    [Sun Jul 17 09:20:46 2005] [warn] module mod_bwlimited.c is already added, skipping
    [Sun Jul 17 09:20:46 2005] [warn] module mod_log_bytes.c is already added, skipping
    [Sun Jul 17 09:20:46 2005] [warn] module mod_auth_passthrough.c is already added, skipping
    /etc/rc.d/init.d/httpd start: httpd started
    I get the same error with Curl and Curl SSL selected or just Curl. When it does that error, php is not installed... it just continues to use the previous built php install. I've been able to successfullly build php as long as I deselect the two Curl options.

    I don't think it's terribly important right now, since I don't think I have any scripts currently using curl. But it would be nice to get this fixed. Anyone have any other ideas?

    I thought it might be related to me manually upgrading Curl, but I checked and the newer version I installed is in a different location:

    Code:
    root@spiffy [/scripts]# /usr/bin/curl -V
    curl 7.12.0 (i686-pc-linux-gnu) libcurl/7.12.0 zlib/1.1.4
    Protocols: ftp gopher telnet dict ldap http file
    Features: Largefile libz
    root@spiffy [/scripts]# /usr/local/bin/curl -V
    curl 7.13.1 (i686-pc-linux-gnu) libcurl/7.13.1 OpenSSL/0.9.7a zlib/1.1.4
    Protocols: ftp gopher telnet dict ldap http file https ftps
    Features: Largefile NTLM SSL libz
    
    The older Curl doesn't seem to be built with OpenSSL though... is that the problem?
     
    #5 dezignguy, Jul 17, 2005
    Last edited: Jul 17, 2005
  6. matt621

    matt621 Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    what was your solution to this?
     
Loading...

Share This Page