The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Fails

Discussion in 'EasyApache' started by mike25, Sep 22, 2010.

  1. mike25

    mike25 Well-Known Member

    Joined:
    Aug 29, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Raleigh NC, USA
    I have this little script I wrote a long time ago to kill various services and restart them in the event of a load spike. It was working well for a long time but recently it seems this creates some problem for Apache .. The script runs properly, kills apache and restarts it, but at some point within the next hour apache becomes unresponsive. I can see several processes running from the shell, but the whm-server-status link times out as do any other requests. I just login and run the same commands in the script to restart apache and its good as new. what could be causing this to occur ?
     
    #1 mike25, Sep 22, 2010
    Last edited: Sep 23, 2010
  2. mike25

    mike25 Well-Known Member

    Joined:
    Aug 29, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Raleigh NC, USA
    no clues anyone ?
     
  3. WiredTree Joe

    WiredTree Joe Well-Known Member
    PartnerNOC

    Joined:
    Dec 13, 2006
    Messages:
    68
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Chicago, IL
    When Apache is running but unresponsive, what do you see in the error log?
     
Loading...

Share This Page