Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Apache gateway timeout after a while

Discussion in 'EasyApache' started by Shift body, Nov 30, 2018.

  1. Shift body

    Shift body Registered

    Joined:
    Nov 30, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Iran
    cPanel Access Level:
    Root Administrator
    Hi,
    In the last days i had a problem with my server. Apache shows me 504 gateway timeout after a while when i switch sites to it while they are completely ok with litehttpd. When i switch to apache, after about an hour, i get gateway timeout on the sites ( written in text at the top left of the page ). I tried rebuilding apache configuration but didnt workout. I tried changing php handler, and changing configuration from ea4 but none of above could help solve the problem. Did anyone else have a such problem? And can you guys help me where the problem might come from? ( what we can be sure about is dns not having problem cause sites are ok with litespeed ).
     
  2. Shift body

    Shift body Registered

    Joined:
    Nov 30, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Iran
    cPanel Access Level:
    Root Administrator
    anybody knows where the problem comes from?
     
  3. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,817
    Likes Received:
    275
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @Shift body


    Have you checked the apache error logs when the timeouts start to occur? They're located at:

    Code:
    /etc/apache2/logs/error_log

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Shift body

    Shift body Registered

    Joined:
    Nov 30, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Iran
    cPanel Access Level:
    Root Administrator
    hi,
    thanks for your response. these lines might be what you meant...

    [Thu Nov 29 19:30:23.803033 2018] [proxy_fcgi:error] [pid 10610:tid 47872239466240] (70007)The timeout specified has expired: [client ip:0] AH01075: Error dispatching request to$

    [Thu Nov 29 19:30:50.917185 2018] [proxy_fcgi:error] [pid 10415:tid 47872210048768] (70007)The timeout specified has expired: [client ip:0] AH01075: Error dispatching request t$


    the point is that i changed apache timeout but the problem didn't get solved. i setted 450 for timeout, and 100 for keep-alive timeout... this problem occured for 4 servers i have since ip upgraded from cp 74 to 76.0.8... but the weird thing is that not all the server have this problem... i have 2 servers running 76.0.10 and 76.0.8 and they are ok while 4 servers having problem with it... one of these 4 server has fresh cpanel installed! and there is only 2 sites on it.... sites were ok when they were on the old server, since i transfered them to the new server, they get this message whic i sent.

    thanks.
     
  5. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,817
    Likes Received:
    275
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice