The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache goes down when addon domain is created.

Discussion in 'EasyApache' started by gr8ex, Jan 11, 2005.

  1. gr8ex

    gr8ex Member

    Joined:
    Sep 30, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Hi,


    When I use the park/point a domain option in my WHM it shows bind reloading, then adding entry to httpd.conf and after that apache goes down. Anybody got any idea what the issue may be. There was a similar issue when I created an account and it was fixed when I edited the script /scripts/wwwacct changed the safeapacherestart to /scriptsrestartsrv httpd. But in this case I dont know which script to edit.

    Any help is appreciatred.....

    Thank you :)
     
  2. hostcp3

    hostcp3 Well-Known Member

    Joined:
    Jun 18, 2002
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    Problem is when you start editing cpanel scripts you could be making things worse and cause other issues.

    you can always update the full scripts directory by running

    rsync -av rsync://rsync.cpanel.net/scripts /scripts

    and that will update the full scripts directory you might

    mv /scripts /scripts.bak

    mkdir /scripts

    first.

    Also we had an issue with /scriptsrestartsrv httpd causing http to stop a while back, a forced update of cpanel to edge appeared to fix it.
     
  3. gr8ex

    gr8ex Member

    Joined:
    Sep 30, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Apache goes down when addon domain created

    Thanks of the reply ........ :)
    The issue is that the "safeapacherestart " which iis used in some of the scripts do not work...what may be the reason? that was why i replaced the "safeapacherestart " with /scritpts/restartsrv httpd and it worked.. but the scripts which parks/points a domain ends up with the termination of httpd and I have to manuallly start it everytime..
    Any ideasssssss?
    Even the forced upcp did not work..
     
Loading...

Share This Page