apache goes down when addon domain is created.

gr8ex

Member
Sep 30, 2004
23
0
151
Hi,


When I use the park/point a domain option in my WHM it shows bind reloading, then adding entry to httpd.conf and after that apache goes down. Anybody got any idea what the issue may be. There was a similar issue when I created an account and it was fixed when I edited the script /scripts/wwwacct changed the safeapacherestart to /scriptsrestartsrv httpd. But in this case I dont know which script to edit.

Any help is appreciatred.....

Thank you :)
 

hostcp3

Well-Known Member
Jun 18, 2002
156
0
166
Problem is when you start editing cpanel scripts you could be making things worse and cause other issues.

you can always update the full scripts directory by running

rsync -av rsync://rsync.cpanel.net/scripts /scripts

and that will update the full scripts directory you might

mv /scripts /scripts.bak

mkdir /scripts

first.

Also we had an issue with /scriptsrestartsrv httpd causing http to stop a while back, a forced update of cpanel to edge appeared to fix it.
 

gr8ex

Member
Sep 30, 2004
23
0
151
Apache goes down when addon domain created

Thanks of the reply ........ :)
The issue is that the "safeapacherestart " which iis used in some of the scripts do not work...what may be the reason? that was why i replaced the "safeapacherestart " with /scritpts/restartsrv httpd and it worked.. but the scripts which parks/points a domain ends up with the termination of httpd and I have to manuallly start it everytime..
Any ideasssssss?
Even the forced upcp did not work..