premnath

Registered
Nov 29, 2016
1
0
1
Chennai, India
cPanel Access Level
Root Administrator
Hi Team,

I am new for cPanel.

Issue is apache server is restarting automatically from through cpanel. I will be going randomly

As a result the DirectoryRoot which i assign will be changed to default /var/www/html.

My directoryroot path - /home/live/public_html/.


Please find log in error_log file.

Code:
[Wed Apr 19 05:59:28.780185 2017] [core:error] [pid 5495] (2)No such file or directory: AH00095: failed to remove PID file /run/apache2/httpd.pid
[Wed Apr 19 05:59:28.780213 2017] [mpm_prefork:notice] [pid 5495] AH00169: caught SIGTERM, shutting down
[Wed Apr 19 05:59:28.923407 2017] [suexec:notice] [pid 4521] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Apr 19 05:59:28.924384 2017] [:notice] [pid 4521] ModSecurity for Apache/2.9.0 (ModSecurity: Open Source Web Application Firewall) configured.
[Wed Apr 19 05:59:28.924389 2017] [:notice] [pid 4521] ModSecurity: APR compiled version="1.5.2"; loaded version="1.5.2"
[Wed Apr 19 05:59:28.924391 2017] [:notice] [pid 4521] ModSecurity: PCRE compiled version="8.32 "; loaded version="8.32 2012-11-30"
[Wed Apr 19 05:59:28.924392 2017] [:notice] [pid 4521] ModSecurity: LUA compiled version="Lua 5.1"
[Wed Apr 19 05:59:28.924394 2017] [:notice] [pid 4521] ModSecurity: LIBXML compiled version="2.9.1"
[Wed Apr 19 05:59:28.924395 2017] [:notice] [pid 4521] ModSecurity: Status engine is currently disabled, enable it by set SecStatusEngine to On.
[Wed Apr 19 05:59:28.926002 2017] [so:warn] [pid 4521] AH01574: module rewrite_module is already loaded, skipping
[Wed Apr 19 05:59:28.938833 2017] [mpm_prefork:notice] [pid 4522] AH00163: Apache/2.4.25 (cPanel) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 configured -- resuming normal operations
[Wed Apr 19 05:59:28.938849 2017] [core:notice] [pid 4522] AH00094: Command line: '/usr/sbin/httpd'
[Wed Apr 19 05:59:29.673064 2017] [mpm_prefork:notice] [pid 4522] AH00169: caught SIGTERM, shutting down
[Wed Apr 19 05:59:30.131136 2017] [suexec:notice] [pid 4644] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Apr 19 05:59:30.132125 2017] [:notice] [pid 4644] ModSecurity for Apache/2.9.0 (ModSecurity: Open Source Web Application Firewall) configured.
[Wed Apr 19 05:59:30.132130 2017] [:notice] [pid 4644] ModSecurity: APR compiled version="1.5.2"; loaded version="1.5.2"
[Wed Apr 19 05:59:30.132132 2017] [:notice] [pid 4644] ModSecurity: PCRE compiled version="8.32 "; loaded version="8.32 2012-11-30"
[Wed Apr 19 05:59:30.132133 2017] [:notice] [pid 4644] ModSecurity: LUA compiled version="Lua 5.1"
[Wed Apr 19 05:59:30.132135 2017] [:notice] [pid 4644] ModSecurity: LIBXML compiled version="2.9.1"
[Wed Apr 19 05:59:30.132136 2017] [:notice] [pid 4644] ModSecurity: Status engine is currently disabled, enable it by set SecStatusEngine to On.
[Wed Apr 19 05:59:30.133642 2017] [so:warn] [pid 4644] AH01574: module rewrite_module is already loaded, skipping
[Wed Apr 19 05:59:30.146253 2017] [mpm_prefork:notice] [pid 4645] AH00163: Apache/2.4.25 (cPanel) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 configured -- resuming normal operations
[Wed Apr 19 05:59:30.146266 2017] [core:notice] [pid 4645] AH00094: Command line: '/usr/sbin/httpd'
[Wed Apr 19 05:59:50.961046 2017] [mpm_prefork:notice] [pid 4645] AH00171: Graceful restart requested, doing restart
[Wed Apr 19 05:59:51.010709 2017] [so:warn] [pid 4645] AH01574: module rewrite_module is already loaded, skipping
[Wed Apr 19 05:59:51.021396 2017] [mpm_prefork:notice] [pid 4645] AH00163: Apache/2.4.25 (cPanel) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 configured -- resuming normal operations
[Wed Apr 19 05:59:51.021403 2017] [core:notice] [pid 4645] AH00094: Command line: '/usr/sbin/httpd'
Please suggest me how to resolve this issue.


Thanks & Regards


Premnath
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
As a result the DirectoryRoot which i assign will be changed to default /var/www/html.

My directoryroot path - /home/live/public_html/.
Hello,

Graceful restarts are a normal occurrence with Apache, and it's explained at:

Why is apache restarting every two hours?

However, the document root of the primary domain name associated with an account is "/home/$username/public_html". Have you made any custom changes to alter the Apache configuration or the account's document root?

Thank you.