Apache "Gracefully finishing" not too much... problems.

fenixer

Well-Known Member
Feb 23, 2007
92
0
156
Hello.....

First of all my specs:

Code:
Timeout 12
KeepAlive Off
MaxKeepAliveRequests 100
KeepAliveTimeout 15
MinSpareServers 20
MaxSpareServers 30
StartServers 30
MaxClients 150
MaxRequestsPerChild 200
WHM 11.11.0 cPanel 11.15.0-R17665 at FC6

The problem is this (from Apache Status):

Code:
Server Built: Oct 19 2007 02:36:32
Current Time: Saturday, 20-Oct-2007 10:03:38 CEST
Restart Time: Friday, 19-Oct-2007 16:13:59 CEST
Parent Server Generation: 8
Server uptime: 17 hours 49 minutes 39 seconds
Total accesses: 544740 - Total Traffic: 4.3 GB
CPU Usage: u282.56 s5.28 cu0 cs.01 - .449% CPU load
8.49 requests/sec - 69.7 kB/second - 8.2 kB/request
16 requests currently being processed, 21 idle servers

RG_____W_G_G_GR_G__G._W____G_G___...GG.W_...G..
continue...

Code:
Scoreboard Key:
"_" Waiting for Connection, "S" Starting up, "R" Reading Request,
"W" Sending Reply, "K" Keepalive (read), "D" DNS Lookup,
"L" Logging, "G" Gracefully finishing, "." Open slot with no current process

Srv	PID	Acc	M	CPU	SS	Req	Conn	Child	Slot	Host	VHost	Request
0-8	7894	0/114/15105	R 	7.66	34	51	0.0	0.56	137.47 	?	?	..reading..
1-6	3579	0/113/9902	G 	8.50	38445	0	0.0	0.71	69.81 	66.249.66.195	(unavailable)	GET /index.php?option=com_fireboard&Itemid=43&func=post&do=repl
Well... as you can see, I like to configure a top of 200 for MaxRequestsPerChild, forcing childs to keep fresh and renew them, just to keep clean my memory and resources..

I do not know if it has to do with it, but I have my servers plenty of "Gracefully finishing" child process... they are there, forever and ever....

If I try to do a graceful restart to httpd, it really do, but the G child procceses keep being there..... they are something like "terminator childs" eating my resources with no sense at all.

As you can see at apache status, this "finishing" child is there for 38450 seconds since beginning of most recent request, so.......................... mmmmmmmmmm........ I think the question is obvious.

Only an httpd restart does the best for this G proccesses.

Someone could please tell me where is the problem?