The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache httpd.conf every virtual host using port 8888 and not 80

Discussion in 'EasyApache' started by Saint Isaiah, Aug 29, 2011.

  1. Saint Isaiah

    Saint Isaiah Registered

    Joined:
    Aug 29, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    First of all, I'm terribly sorry if this has been posted before, but I spent about 45 minutes searching on both here and Google without a single result that relates to this issue.

    I've had my few websites running on a big, beefy server (Phenom II Thuban X6, 8GB RAM, 2x 1.5TB HDD) for a few months now and it worked great. However I didn't realize how much hardware I got for such a low price when checking the competition and decided to get a smaller server (ATOM, 4GB RAM, 2x 1.5TB HDD) for my websites and use the big one for my first fleet of game servers.

    I copied all the accounts over without a problem and proceeded to transfer my cPnginx license over as well. I now noticed that even though the copied accounts all work fine, whenever I make a new account based on a TLD or subdomain, the httpd.conf file has every virtual host (including the server hostname) as "hostname.tld:8888" or "*.*.*.*:8888" as the record rather than "hostname.tld:80" or "*.*.*.*:80".

    Is there something specifically I should start looking at to fix this, because I plan on selling shared hosting accounts and this will be quite a hassle if everytime a new account is made, the websites will cease to function unless I change "8888" to "80" and restart apache.
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please check in WHM > Tweak Settings for this option:

    If it is set to 8888 rather than 80, it would set every account in Apache's configuration (/usr/local/apache/conf/httpd.conf) to be under port 8888 rather than using port 80.
     
  3. Saint Isaiah

    Saint Isaiah Registered

    Joined:
    Aug 29, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    THANK YOU THANK YOU THANK YOU!!!! For some weird reason it was set off the default to 0.0.0.0:8888. changed it to default and it's working perfectly.
     
Loading...

Share This Page