The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache interface/port

Discussion in 'EasyApache' started by Kheldin, Dec 13, 2007.

  1. Kheldin

    Kheldin Member

    Joined:
    Dec 5, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Okay maybe I'm doing something wrong, but all I'm trying to do is simply bind apache on 1 of my IP addresses instead of them all. I've searched through the forums, but everything is a little inconsistent here. 1 guy says edit the httpd.conf, someone else says something else..

    So I looked under the 'Tweak Settings' and low and behold, there is a spot like this:

    The port on which Apache listens for HTTP connections. Specifying a specific IP will prevent Apache from listening on all other IPs. (default: 0.0.0.0:80)

    And naturally its set to 0.0.0.0:80 which makes it listen on all ports. You'd think that changing this setting would do what it says, however, in my case it does absolutely nothing. I've changed it (along with the setting under it for SSL) to the 1 IP address I want it to listen to, click 'Save' only to find out.... it doesn't work.

    Whats the point of this setting I'm wondering.. when I hit 'Save' it says it saved my changes, but when I click on Tweak Settings again, its back at 0.0.0.0:80.

    I've stopped, started, restarted apache to no avail.

    My question, what does that setting do, because I can't seem to get it to do anything. Also, if I edit the httpd.conf file directly, will my changes remain on server reboot / upgrades?
     
  2. Kheldin

    Kheldin Member

    Joined:
    Dec 5, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Can anyone help me on this?

    I edited the file /var/cpanel/cpanel.config and changed the apache_port and the apache_ssl_port settings, and then, as instructed at the top of the file, ran /usr/local/cpanel/whostmgr/bin/whostmgr2 --updatetweaksettings and the output it gives me is:

    Updating "Apache Non-SSL Port" from "xxx.xxx.xxx.xxx:80" to "0.0.0.0:80".
    Succeeded
    "Apache Non-SSL Port" was updated.
    Updating "Apache SSL Port" from "xxx.xxx.xxx.xxx:443" to "0.0.0.0:443".
    Succeeded
    "Apache SSL Port" was updated.
    Done.

    where xxx.xxx.xxx.xxx is the IP address I changed it to. It sets it back to 0.0.0.0:80 !!

    What gives? What am I doing wrong, seems that I've followed the directions, but it refuses to let me set the Listen directive.
     
Loading...

Share This Page