The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache issues....won't restart

Discussion in 'EasyApache' started by Secret Agent, May 26, 2005.

  1. Secret Agent

    Secret Agent Guest

    root@server3 [/var/log]# service httpd start
    /etc/init.d/httpd start: httpd could not be started

    /scripts/easyapche
    httpd failed...please contact sys admin

    tail -f /usr/local/apache/logs/error_log

    [Thu May 26 22:23:03 2005] [error] [client xx.x86.220.209] File does not exist: /home/ahweddin/public_html/style.css
    [Thu May 26 22:23:04 2005] [error] [client xx.x86.220.209] File does not exist: /home/ahweddin/public_html/images-files/transpix.gif

    root@server3 [/var/log]# /etc/init.d/httpd startssl
    /etc/init.d/httpd startssl: httpd could not be started

    root@server3 [/var/log]# httpd configtest
    root@server3 [/var/log]#


    Anyone???
     
  2. Secret Agent

    Secret Agent Guest

    I also get this during compiling (this is in red)

    Code:
    validity EXSLT/downloads.html:3: error : validity Validation failed: no DTD found !
    error : <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
    Validation failed: no DTD found !
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    I/O <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
    error :                                           ^
    Attempt to load network entity http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    EXSLT/index.html:1: parser error : Document is empty
    
    ^
    EXSLT/index.html:1: parser error : Start tag expected, '<' not found
    
    ^
    Attempt to load network entity http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
    EXSLT/intro.html:3:                                           ^
    validity error : Validation failed: no DTD found !
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    EXSLT/index.html:1: parser error : Document is empty
    
    ^
    EXSLT/index.html:1: parser error : Start tag expected, '<' not found
    
    ^
    Validation failed: no DTD found !
    EXSLT/help.html:3: <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
    validity error :                                           ^
    Validation failed: no DTD found !
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    EXSLT/index.html:1: parser error : Document is empty
    
    ^
    EXSLT/index.html:1: parser error : Start tag expected, '<' not found
    
    ^
    validity error : make[2]: Validation failed: no DTD found !
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    <html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
                                              ^
    
    
     
  3. Secret Agent

    Secret Agent Guest

    From another thread a fix was to run this:

    mv /usr/local/apache /usr/local/apache.OLD
    /scripts/easyapache
    (tried #8, #6 as well)

    initfpsuexec: using apache 1.x support
    PHP version file is up to date
    Executing /scripts/postbuildapache (if exists)...Done
    httpd: no process killed
    /etc/rc.d/init.d/httpd start: httpd could not be started
    Waiting for httpd to restart..............finished.


    httpd has failed, please contact the sysadmin.

    Done both, still not working

    /usr/local/apache/logs/error_log

    [Thu May 26 23:39:08 2005] [error] mod_ssl: Init: Unable to read server certificate from file /usr/local/apache/conf/ssl.crt/server.crt (OpenSSL library error follows)
    [Thu May 26 23:39:08 2005] [error] OpenSSL: error:0D06B08E:asn1 encoding routines:ASN1_d2i_bio:not enough data
    [Thu May 26 23:39:15 2005] [error] mod_ssl: Init: Unable to read server certificate from file /usr/local/apache/conf/ssl.crt/server.crt (OpenSSL library error follows)
    [Thu May 26 23:39:15 2005] [error] OpenSSL: error:0D06B08E:asn1 encoding routines:ASN1_d2i_bio:not enough data
     
    #3 Secret Agent, May 26, 2005
    Last edited by a moderator: May 27, 2005
  4. Secret Agent

    Secret Agent Guest

    $ openssl x509 -req -days 60 -in server.csr -signkey server.key -out server.crt
    -bash: $: command not found


    nothing will work

    Also, httpd.conf is at /usr/local/apache/conf/httpd.conf but no longer found at /etc/httpd/etc/httpd.conf (was there before)
     
    #4 Secret Agent, May 27, 2005
    Last edited by a moderator: May 27, 2005
  5. Secret Agent

    Secret Agent Guest

    :(

    There are no accounts listed in WHM now and httpd.conf has no virtual hosts at all

    I ran /scripts/rebuildhttpdconf

    I went into nano /etc/httpd/conf/httpd.conf and the virtual hosts for the accounts are still not there ???
     
    #5 Secret Agent, May 27, 2005
    Last edited by a moderator: May 27, 2005
  6. Secret Agent

    Secret Agent Guest

    Someone please help me.

    I'm still not able to resolve this
     
Loading...

Share This Page