The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Issues

Discussion in 'EasyApache' started by Lestat, Apr 27, 2005.

  1. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    New Cpanel Install.
    I am having major issues on getting a fresh install working. Apache will not run. This is what I get on a apache build.

    Building Apache Config.....Done
    Downloading and compiling apache+modules....


    Verifying archive integrity... All good.
    Uncompressing buildapache..........................................................................................................................
    Verifying compiler and libs....Sync Source: http://httpupdate.cpanel.net/RELEASE/scripts
    Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE/scripts/.cpanelsync.lock....Trying httpupdate.cpanel.net @ 69.72.164.151
    100%......Done
    Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE/scripts/.cpanelsync.bz2....Trying httpupdate.cpanel.net @ 69.72.164.152
    34%...68%...100%......Done
    Verifying installation....Gathering header information file(s) from server(s)
    Server: Fedora Core 2 - i386 - Base
    Server: Fedora Core 2 - i386 - Released Updates
    Finding updated packages
    Downloading needed headers
    No actions to take
    wget is installed and is the latest version.
    Gathering header information file(s) from server(s)
    Server: Fedora Core 2 - i386 - Base
    Server: Fedora Core 2 - i386 - Released Updates
    Finding updated packages
    Downloading needed headers
    Resolving dependencies
    .Dependencies resolved
    I will do the following:
    [install: libstdc++-devel 3.3.3-7.i386]
    [install: libpng10 1.0.18-1.fc2.i386]
    [install: aspell-devel 12:0.50.3-19.1.i386]
    [install: libtool 1.5.6-1.i386]
    [install: pam-devel 0.77-40.i386]
    [install: xorg-x11-devel 6.7.0-14.i386]
    [install: libpng10-devel 1.0.18-1.fc2.i386]
    [install: bison 1.875c-1.i386]
    [install: patch 2.5.4-19.i386]
    [install: gdbm-devel 1.8.0-22.1.i386]
    [install: ncurses-devel 5.4-5.i386]
    [install: db4-devel 4.2.52-3.1.i386]
    [install: libungif-devel 4.1.0-17.1.i386]
    [install: libtiff-devel 3.5.7-22.fc2.i386]
    [install: gcc-c++ 3.3.3-7.i386]
    [install: flex 2.5.4a-31.1.i386]
    I will install/upgrade these to satisfy the dependencies:
    [deps: pkgconfig 1:0.15.0-1.1.i386]
    [deps: fontconfig-devel 2.2.1-10.i386]
    [deps: autoconf 2.59-3.noarch]
    [deps: automake 1.8.3-1.noarch]
    Downloading Packages
    Getting libstdc++-devel-3.3.3-7.i386.rpm
    ncurses is installed and is the latest version.
    gettext is installed and is the latest version.
    gdbm is installed and is the latest version.
    db4 is installed and is the latest version.
    glibc-kernheaders is installed and is the latest version.
    krb5-devel is installed and is the latest version.
    openssl is installed and is the latest version.
    openssl-devel is installed and is the latest version.
    glibc-devel is installed and is the latest version.
    gcc is installed and is the latest version.
    cpp is installed and is the latest version.
    libstdc++ is installed and is the latest version.
    libjpeg is installed and is the latest version.
    libjpeg-devel is installed and is the latest version.
    libpng is installed and is the latest version.
    libpng-devel is installed and is the latest version.
    libtiff is installed and is the latest version.
    zlib is installed and is the latest version.
    zlib-devel is installed and is the latest version.
    aspell is installed and is the latest version.
    libc-client-devel is installed and is the latest version.
    retrygrab() failed for:
    http://mirror.linux.duke.edu/pub/fe.../Fedora/RPMS/libstdc++-devel-3.3.3-7.i386.rpm
    Executing failover method
    failover: out of servers to try
    Error getting file http://mirror.linux.duke.edu/pub/fe.../Fedora/RPMS/libstdc++-devel-3.3.3-7.i386.rpm
    [Errno 4] IOError: HTTP Error 404: Not Found
    Done
    Done
    ********************************
    This is buildapache version 10.0.1b
    ********************************
    buildapache configured from Web Host Manager
    Apache configured from Web Host Manager!
    Untarring expat...Done

    configure expat-1.95.6...(--prefix=/usr).... . . . . Done

    make -j 1 expat-1.95.6....... . . . . . . . . . . . . . Done

    make expat-1.95.6...(install).... Done
    Untarring apache....
    Suexec Standard Patch
    Suexec MailMan Patch
    Fileprotect Suexec Standard Patch
    HTTPS var Standard Patch

    configure apache_1.3.33...(--enable-shared=max).... . . . . Done
    Untarring modssl....

    configure mod_ssl-2.8.22-1.3.33...(--with-apache=../apache_1.3.33 --with-ssl=/usr --enable-module=expires --enable-shared=expires --add-module=../mod_frontpage.c --enable-module=rewrite --enable-shared=rewrite --enable-suexec --suexec-logfile=/usr/local/apache/logs/suexec_log --suexec-caller=nobody --suexec-uidmin=100 --suexec-gidmin=100 --suexec-docroot=/ --suexec-userdir=public_html).... . . . . . . . . . Done

    configure apache_1.3.33...(--enable-module=ssl --enable-module=expires --enable-shared=expires --add-module=../mod_frontpage.c --enable-module=rewrite --enable-shared=rewrite --enable-suexec --suexec-logfile=/usr/local/apache/logs/suexec_log --suexec-caller=nobody --suexec-uidmin=100 --suexec-gidmin=100 --suexec-docroot=/ --suexec-userdir=public_html).... . . . . . Done

    make -j 1 apache_1.3.33....... . . . . . . . . . . . . . . . . . Done
    make[4]: *** [ssl_expr_scan.c] Error 127
    make[3]: *** [all] Error 1
    make[2]: *** [subdirs] Error 1
    make[1]: *** [build-std] Error 2
    make: *** [build] Error 2

    make apache_1.3.33...(install).... Done
    make[5]: *** [ssl_expr_scan.c] Error 127
    make[4]: *** [all] Error 1
    make[3]: *** [subdirs] Error 1
    make[2]: *** [build-std] Error 2
    make[1]: *** [build] Error 2
    make: *** [install-all] Error 2
    /etc/rc.d/init.d/httpd start: httpd could not be started
    Setting /home permissions to 0711......Done
    Setting permissions for.....nfsnobody...cpanel...mailman...clamav......Done

    configure zziplib-0.13.36...(--prefix=/usr).... . . . . . . . . . Done

    make -j 1 zziplib-0.13.36....... . . . . . . . . . . . Done

    make zziplib-0.13.36...(install).... . . . . . . . . . . . . . . . . . . . . . . Done
    Untarring flash......Done
    Untarring imap....Gathering header information file(s) from server(s)
    Server: Fedora Core 2 - i386 - Base
    Server: Fedora Core 2 - i386 - Released Updates
    Finding updated packages
    Downloading needed headers
    No actions to take
    libc-client-devel is installed and is the latest version.
    Untarring php....Done
    Applying CURL curl_formfree patch

    configure php-4.3.11...(--with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --with-swf=/usr/local/flash --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-imap --with-imap-ssl --with-kerberos --enable-magic-quotes --with-mysql --with-snmp --enable-ucd-snmp-hack --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zip --with-zlib).... . . Done
    configure: error: cannot find output from lex; giving up

    make -j 1 php-4.3.11...(clean)...Done

    make -j 1 php-4.3.11....... Done

    make php-4.3.11...(install)...Done
    /etc/rc.d/init.d/httpd start: httpd could not be started

    configure php-4.3.11...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --with-swf=/usr/local/flash --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-imap --with-imap-ssl --with-kerberos --enable-magic-quotes --with-mysql --with-snmp --enable-ucd-snmp-hack --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zip --with-zlib).... . Done
    configure: error: cannot find output from lex; giving up

    make -j 1 php-4.3.11...(clean)...Done

    make -j 1 php-4.3.11....... Done

    make php-4.3.11...(install)...Done
    initfpsuexec: using apache 1.x support
    PHP version file has been updated to
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd could not be started
    Attempting to restart httpd
    Waiting for httpd to restart....
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    finished.


    httpd status


    httpd has failed, please contact the sysadmin.
    Build Complete
     
  2. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    Nevermind figured it out it was my yum.conf had to update to a new address for downloads.
     
  3. arkain

    arkain Well-Known Member

    Joined:
    Mar 20, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    what is the new address?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you're having problems with your yum mirror, you should visit the OS vendors site for the OS you use and look for their list of mirrors and choose one close to you and then reconfigure yum.conf to use it.
     
  5. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    That mirror thing is a very common problem I see around yum users in FC1 and FC2. Not sure about FC3 but in FC4 (or new version of yum), they have separated the yum repository setup method and they have a line for mirror that refers to a repository of yum update mirrors. From there, yum will tryto update from tons of mirror sites from the list which eliminate this out of server to download rpm problems.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The main issue with FC1 and FC2 is that they're EOL and a lot of the Fedora mirrors dropped them as soon as they went that way. If you check the mirrors on the FedoraLegacy site they're usually more reliable in that regard:
    http://fedoralegacy.org/download/fedoralegacy-mirrors.php
     
Loading...

Share This Page