The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Java

Discussion in 'EasyApache' started by bsdjunk, Jan 30, 2008.

  1. bsdjunk

    bsdjunk Member

    Joined:
    Jan 15, 2008
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Does the default apache have anything to do with java? Meaning does it support java applets ? As checking my server with Nessus gives me 1 hole saying I need to upgrade tomcat to 3.3.1 I don't use tomcat and I am out of luck. This could be a false alarm but thought I would check here. Also easyapache doesn't offer anything to compile tomcat ? Any input or help is appreciated.

    This is for informational purposes. this is on a cpanel 11 rel 19434 on freebsd.

    Apache Tomcat (prior to 3.3.1a) is prone to a directory listing and file
    disclosure vulnerability, it allows remote attackers to potentially list
    directories even with an index.html or other file present, or obtain
    unprocessed source code for a JSP file.


    Solution Upgrade to Tomcat 4.1.18 or newer version.


    Risk Factor : High
    CVE : CVE-2003-0042
    BID : 6721
    Plugin ID : 11438
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Tomcat is not compiled by default. You can compile this via the EasyApache interface (WHM -> Software -> Apache Update) by checking the box for Tomcat. The version of Tomcat currently supported is 5.5.9.

    You should only use cPanel/WHM's Tomcat functionality if you are an experienced Tomcat administrator.
     
  3. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The version of Tomcat that EasyApache installs is 5.5.21
     
  4. appservermgr

    appservermgr Member

    Joined:
    Feb 16, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    If you are only looking for JAVA Applet support, then you do not need any application server installed, as applets are processed on the client side.
     
Loading...

Share This Page