The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache MaxClients

Discussion in 'EasyApache' started by yoachan, Aug 7, 2010.

  1. yoachan

    yoachan Well-Known Member

    Joined:
    Jan 10, 2010
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Dear all,

    I wanted to increase my Apache's MaxClient.
    In Service Configuration >> Apache Configuration >> Global Configuration said that "This interface allows up to the default of 256.". From what I read, I need to increase Apache's ServerLimit.
    Because I can't find it at Global Configuration, I opened my httpd.conf using ssh, and added
    Code:
    ServerLimit 512
    and change
    Code:
    MaxClients 512
    than restart my Apache service.

    My question is:
    1. Will this works?
    2. When I look at WHM Apache Global Configuration, I still see 256 as my MaxClients instead of 512 as I expected. Why is that so?
    3. We have a quad core processor and 8GB RAM, and currently the machine is just sitting there with no heavy processes. Any idea how much MaxClients that my machine can afford? Because all this time the one that peak out is our MaxClients.

    Any ideas appreciated.

    Regards,

    YoChan
     
  2. arunsv84

    arunsv84 Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    373
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
  3. yoachan

    yoachan Well-Known Member

    Joined:
    Jan 10, 2010
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    @arunsv84
    Thanks for your reply

    I've add
    Code:
    ServerLimit 512
    in Pre Main Include section for Apache 2.2.16 which I use. But still when I want to edit Apache Global Configuration, I still see this note:
    Code:
    This interface allows up to the default of 256.
    and when I change the MaxClients to 512, I get this red warning:

    Code:
    Value (512) is over the limit (256), using previously saved value (if any) or default (150)
    and my maxclients was reset back to 256...

    Did I missed anything?
     
  4. yoachan

    yoachan Well-Known Member

    Joined:
    Jan 10, 2010
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    any ideas???? :(
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,463
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    In your WHM > Service Configuration > Apache Configuration > Global Configuration you'll find some settings you may be interested in.
    (That thread linked above here is out of date)
     
  6. yoachan

    yoachan Well-Known Member

    Joined:
    Jan 10, 2010
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Yes, there are some settings, but still no answer for my question.......
     
  7. CoreISP.net

    CoreISP.net Active Member

    Joined:
    May 25, 2006
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    DataCenter Provider
    For Apache 2:

    Modify /usr/local/apache/conf/includes/pre_virtualhost_global.conf
    and add these lines:

    ServerLimit 2048
    MaxClients 2048

    and then restart Apache.

    This is to set it to 2048, ofcourse you can modify it to whatever you want.
    For Apache 1.3 just modify httpd.conf's MaxClients setting.
     
  8. whr

    whr Active Member

    Joined:
    Jul 25, 2009
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    India
    Try the below syntax in httpd.conf file:

    <IfModule prefork.c>
    ServerLimit 512
    MaxClients 512
    </IfModule>


    Save and quit httpd.conf

    Then run the Apache distiller

    /usr/local/cpanel/bin/apache_conf_distiller --update
     
Loading...

Share This Page