Apache not responding for 5 minutes each day

Erel

Active Member
Jul 23, 2007
29
2
53
We've recently changed to event MPM + PHP FPM and enabled http 2.
Everything seems to be working properly, however every day or so the http server becomes unresponsive for a few minutes.

WHM is accessible when that happens and it doesn't seem to be related to the server load.

I don't think that there is anything interesting in the error log:
Code:
[Tue Aug 08 03:55:49.975649 2017] [ssl:error] [pid 18159:tid 140712028882688] AH02031: Hostname www.removed.com provided via SNI, but no hostname provided in HTTP request
[Tue Aug 08 04:08:05.451154 2017] [proxy_fcgi:error] [pid 30981:tid 140712246781696] (70007)The timeout specified has expired: [client 183.38.65.170:32027] AH01075: Error dispatching request to : (polling), referer: https://www.removed.com/android/forum
[Tue Aug 08 04:08:06.920150 2017] [proxy_fcgi:error] [pid 28044:tid 140712096024320] (70007)The timeout specified has expired: [client 157.55.39.30:2712] AH01075: Error dispatching request to : (polling)
I've enabled piped logging and access_log only shows these messages:
Code:
127.0.0.1 - - [08/Aug/2017:04:10:01 -0400] "GET /whm-server-status HTTP/1.0" 200 86111 "-" "-"
127.0.0.1 - - [08/Aug/2017:04:15:02 -0400] "GET /whm-server-status HTTP/1.0" 200 85383 "-" "-"
127.0.0.1 - - [08/Aug/2017:04:20:01 -0400] "GET /whm-server-status HTTP/1.0" 200 85823 "-" "-"
127.0.0.1 - - [08/Aug/2017:04:25:01 -0400] "GET /whm-server-status HTTP/1.0" 200 86233 "-" "-"
127.0.0.1 - - [08/Aug/2017:04:30:01 -0400] "GET /whm-server-status HTTP/1.0" 200 86237 "-" "-"
127.0.0.1 - - [08/Aug/2017:04:35:01 -0400] "GET /whm-server-status HTTP/1.0" 200 85700 "-" "-"
I'm not sure why all other requests are not logged (there should be many requests all the time).

Anything else that I can check to understand why it happens?
 
Last edited by a moderator:

Erel

Active Member
Jul 23, 2007
29
2
53
I do see this message in php-fpm error_log:

server reached max_children setting (5), consider raising it
I've increased the limit to 20.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello,

Let us know if the issue continues after making that change.

Thank you.