Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache not restarting

Discussion in 'EasyApache' started by compunet2, May 19, 2003.

  1. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    166
    Normally apache restarts every 10 minutes (graceful restart) and starts a new parent generation. However, for the last 30 minutes I've been on generation 0. What could cause this???

    cPanel.net Support Ticket Number:
     
  2. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    318
    tail -f /usr/local/apache/logs/error_log should give you a clue as to what's going on
     
  3. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    166
    Nope... no errors. Apache eventually did restart, however it doesn't seem to be doing it every 10 minutes like I thought it should.... seems to be much longer between restarts...

    cPanel.net Support Ticket Number:
     
  4. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,505
    Likes Received:
    0
    Trophy Points:
    316
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    I have noticed this too. Only happens though, after I have made changes to a config file -- which requires an Apache restart to take effect. It always takes much longer then the usual 10 minutes???

    Oh, well. :D

    cPanel.net Support Ticket Number:
     
  5. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    166
    You know, come to think of it, it did start after I did a restart on apache. I haven't reset the server since, but maybe the apache restart had something to do with it....

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page