The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Not Updating

Discussion in 'EasyApache' started by jackal, Dec 6, 2003.

  1. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    AnyBody having troubles today updating Apache?
    We select options and it runs but it does not install all selections and does not compile PHP. It finishs and does not error out, starts back ok just no changes.

    Wondering if anyone else is seeing the same problem.
     
  2. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    Same here. Apache compiles okay as we removed mod_gzip because of problems and when apache came back, mod_gzip was gone.

    PHP is not compiling though. Here is an excerpt:

    make: *** No targets specified and no makefile found. Stop.
    make: *** No rule to make target `install'. Stop.
    ./build all
    ./build install

    That is what comes up just before httpd restarts. That is the tail end of the php isntall.
     
  3. hiddenshadow

    hiddenshadow Registered

    Joined:
    Nov 24, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Getting the same thing.
     
  4. hiddenshadow

    hiddenshadow Registered

    Joined:
    Nov 24, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Here's the problem. php-4.3.4.tar.gz is corrupt on cpanel.net.

    --01:18:55-- http://layer1.cpanel.net/buildapache/1/php-4.3.4.tar.gz
    => `php-4.3.4.tar.gz'
    Resolving layer1.cpanel.net... done.
    Connecting to layer1.cpanel.net[216.118.116.106]:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 4,630,171 [application/x-tar]

    100%[===========================================================================================================>] 4,630,171 2.65M/s ETA 00:00

    01:18:57 (2.65 MB/s) - `php-4.3.4.tar.gz' saved [4630171/4630171]

    Untarring php....tar: Skipping to next header

    gzip: stdin: invalid compressed data--crc error

    gzip: stdin: invalid compressed data--length error
    tar: Child returned status 1
    tar: Error exit delayed from previous errors
     
  5. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    Aha.

    Anyone from cpanel paying attention to this?

    Hellooooooooo?
     
  6. hiddenshadow

    hiddenshadow Registered

    Joined:
    Nov 24, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    If you're desperate, use PHP 4.3.3 in the meantime. That package seems to be complete.
     
  7. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    Well, we compiled 4.3.4 from source for one client and it seemed to work pretty well. Everything except imap for some reason.
     
Loading...

Share This Page