The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache optimization not reflected

Discussion in 'EasyApache' started by agnivo007, Feb 13, 2009.

  1. agnivo007

    agnivo007 Registered

    Joined:
    Sep 14, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I want to optimize apache and edited the httpd-mpm.conf,default.conf etc. at /usr/local/apache/conf/extras ; ran the distiller but the changes are not reflected like maxclients, timeout, keepalive.

    Kindly point me in the right direction such that the optimizations are used by apache.

    Use latest whm/cpanel release builds.
     
  2. agnivo007

    agnivo007 Registered

    Joined:
    Sep 14, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Anyone, please? The application is quite mission critical; so need it fast.
     
  3. SB-Nick

    SB-Nick Well-Known Member

    Joined:
    Aug 26, 2008
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hiya,

    Just place your settings (be sure you are not overlapping any current one) inside /etc/httpd/conf/httpd.conf and then run /usr/local/cpanel/bin/apache_conf_distiller --update

    That should do it.
     
  4. ChrisRHS

    ChrisRHS Well-Known Member

    Joined:
    Jul 12, 2006
    Messages:
    292
    Likes Received:
    5
    Trophy Points:
    18
    The files you edited I don't believe are included by default, you would need to use the includes editor in WHM to call those files, or, use the includes editor to make your changes. For example, in the "Pre VirtualHost Include", you could put your settings:

    Code:
    KeepAlive Off
    KeepAliveTimeout 2
    MaxKeepAliveRequests 80
    Timeout 90
    Hope this helps.
     
Loading...

Share This Page