The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Performance - sloooooow - help

Discussion in 'EasyApache' started by Ray, Jan 27, 2003.

  1. Ray

    Ray Registered

    Joined:
    Dec 10, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I have the default installation of apache as it came from cPanel.

    I am pushing close to 4 Mbps now on a Dual XEON 2.2 Ghz with 3GB RAM.

    Response time is extremely slow. Can anyone suggest changes I can make to speed up this dog?

    Memory usage seems a bit high too considering the content it is serving accounts for less disk space than memory available.. leak?

    =======================
    MinSpareServers 5
    MaxSpareServers 10
    StartServers 5
    MaxRequestsPerChild 0
    MaxClients 170
    =======================

    Current Time: Monday, 27-Jan-2003 06:58:59 PST
    Restart Time: Monday, 27-Jan-2003 06:40:03 PST
    Parent Server Generation: 2
    Server uptime: 18 minutes 56 seconds
    Total accesses: 1815 - Total Traffic: 33.9 MB
    CPU Usage: u.04 s2.32 cu0 cs0 - .208% CPU load
    1.6 requests/sec - 30.6 kB/second - 19.1 kB/request
    67 requests currently being processed, 1 idle servers


    Server Software: Apache/1.3.27
    Server Hostname: www.lastcache.com
    Server Port: 80

    Document Path: /cab7.GIF
    Document Length: 63363 bytes

    Concurrency Level: 100
    Time taken for tests: 10.630 seconds
    Complete requests: 100
    Failed requests: 0
    Broken pipe errors: 0
    Total transferred: 6514075 bytes
    HTML transferred: 6477883 bytes
    Requests per second: 9.41 [#/sec] (mean)
    Time per request: 10630.00 [ms] (mean)
    Time per request: 106.30 [ms] (mean, across all concurrent requests)
    Transfer rate: 612.80 [Kbytes/sec] received

    Connnection Times (ms)
    min mean[+/-sd] median max
    Connect: 2 1042 1422.2 50 3027
    Processing: 3762 4847 794.4 4946 7424
    Waiting: 3751 4846 794.4 4945 7424
    Total: 3762 5889 1826.4 5275 10450
     
  2. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    A couple of things you may want to try:

    Add the following to your httpd.conf file, anywhere is fine:

    RLimitMEM 139492352
    RLimitCPU 120

    Change the timeout from 300 to 30. Turn keepalive off to conserve system resources. Increase the MaxSpareServers from 10 to say 15 to start. Set maxclients to 400 or so. Disable modules you don't need.

    Once you've gone through the above, be sure to restart apache.
     
Loading...

Share This Page