The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache, PHP and GD

Discussion in 'EasyApache' started by Wallaby, Feb 9, 2004.

  1. Wallaby

    Wallaby Well-Known Member

    Joined:
    Aug 15, 2001
    Messages:
    131
    Likes Received:
    1
    Trophy Points:
    18
    Have been tearing my hair out with recompiling Apache. Tried it in WHM, /scripts/easyapache....

    I cannot get PHP to work with GD enabled. I'd like to get Sablotron working too, but no joy. It's a RedHat 9 box. I've tried various combinations of modules in WHM, no joy. In /scripts/eastapache only the basic config works. All I can end up with is PHP 4.3.3 with a very basic config -- try adding anything extra in and it fails.

    Anyone got this working at all? Seems to be such a fundamental thing, very frustrating!

    (On Windows I can add new modules into PHP oh so simply and can use PHP ISAP to get excellent performance...)
     
  2. vahan

    vahan Active Member

    Joined:
    Dec 10, 2003
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    same here on freebsd 4.9...

    whatever you compile with, apache still runs its out of box, cgi, php 4.2.3 version... gd fails to compile, with 'make: don't know how to make libgd.a. Stop', prolly again something with being not in the proper dir or something. Sablot fails to compile with a configure error too...have filled about 5 support tickets for this... still no fixes. prolly have to hunt Nick in IRC again...
     
  3. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Did you ever get this to work? I'm having the same type of issue. When I compile apache everything seems to work (no errors) but the options don't actually get complied in. I'm trying to get gd and curl support added.

    Strange thing is that this has worked before, but isn't now.

    WHM 8.8.0 cPanel 8.8.0-S74
    RedHat 9 - WHM X v2.1.2
     
  4. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    i had this the other day and support sorted it out it turned out to be some dependancies but i do not know which files

    hope this points you in the right direction

    here i the reply from support

    >
    > after trying easyapache it still has not updated i checked my php info it still
    > says PHP version: 4.3.3 and
    >
    > Image Lib(s)
    >
    > gd
    >
    > module doesn't exist
    >
    > mark

    There are some dependency problems that need to be resolved with XFree86. I'll let you know when I get everything back in shape. :)
    --
     
    #4 swampy, Mar 11, 2004
    Last edited: Mar 11, 2004
  5. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    I've had the same problem, but the sys admin fixed and recompiled PHP
     
  6. brainx

    brainx Member

    Joined:
    Jul 9, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    We had the same problem on one of our Redhat 9 box.

    apache and php 4.3.4 would compile fine without GD support but if you need GD support then you should check for the failed rpm updates after doing a /scripts/rpmup
    On our server the XFree86-devel rpm could not be updated because of some dependencies required.Also the following file was not present on our server:

    /usr/X11R6/lib/libXpm.so

    After doing a force re-install and ignoring dependencies for XFree86-devel the problem got solved.Re-compiling apache with php 4.3.4+GD+FreeType was successful.
     
Loading...

Share This Page