The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache/PHP doesnt work when pdo is enabled

Discussion in 'EasyApache' started by radeonpower, Jul 7, 2012.

  1. radeonpower

    radeonpower Well-Known Member

    Jul 23, 2009
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello, first time I have come across this problem.

    I just setup a VPS and install the latest cPanel on it (WHM 11.32.3 (build 21)).

    I went through easyapache as usual, chose Apache 2.2.22 & php 5.3.13 along with some extensions, pdo and pdo_mysql.

    When the easyapache finishes I cannot choose a handler, it just says 'none'. Anyway, I save the config, open up php.ini and disable Everything works then, I can choose a handler and apache works fine.

    Any idea why this is happening?
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Oct 2, 2010
    Likes Received:
    Trophy Points:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator

    Please go to WHM > Tweak Settings > Max cPanel Process Memory and increase it to 1024 MB instead of 512 (or 256 if you had it that low). Save the area, then see if you can select the PHP handler in WHM > Apache Configuration > PHP and SuExec Configuration area. You should be able to at that point.

    This happens because some PHP modules take more memory to load when that page loads (or that appears to be the case). Only some systems appear to experience this issue, but we have an internal case (56329) about better error detection to allow customers to know that memory is the issue for the handler being blank.


Share This Page