Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Apache problem: httpd not running, trying to start

Discussion in 'EasyApache' started by KamilPRO, Jul 22, 2007.

  1. KamilPRO

    KamilPRO Member

    Joined:
    Sep 24, 2006
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    151
    Please help:

    Code:
    [root@serwer /]# httpd restart
    /usr/sbin/httpd restart: httpd not running, trying to start
    /usr/sbin/httpd restart: httpd could not be started
    Code:
    [root@serwer /]# httpd status
    Looking up localhost
    Making HTTP connection to localhost
    Alert!: Unable to connect to remote host.
    lynx: Can't access startfile http://localhost/server-status
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. pross

    pross Well-Known Member

    Joined:
    Mar 14, 2005
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    156
    root@server [~]# httpd configtest

    whats that produce?
     
  3. KamilPRO

    KamilPRO Member

    Joined:
    Sep 24, 2006
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    151
    Code:
    [root@serwer conf]# httpd configtest
    Syntax OK
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    Is this a VPS or a dedicate server? Run this command and see if there is a httpd process runing, kill it and try to restart. It is very likely that either a Php or Apache module(s) are corrupted. Re-compile Apache and Php using this command: /scripts/easyapache
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #4 AndyReed, Jul 22, 2007
    Last edited: Jul 22, 2007
  5. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,131
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    New York
    Try restarting apache again and then grab the end piece of the apache logs.

    Should be "tail -n 25 /usr/local/apache/logs/error_log > log1.txt"
    also "tail -n 25 /usr/local/apache/logs/access_log > log2.txt"

    Assuming that is the locations of the logs. See what they produce or post the contents of the log1.txt and log2.txt files here.

    You might also want to turn the logging from "warn" to "debug" on the "LogLevel"
    statement in httpd.conf and then restart. Be sure to turn it back to "warn" when done
    or you will get giant logs from now on.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. KamilPRO

    KamilPRO Member

    Joined:
    Sep 24, 2006
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    151
    How long does the recompilation last ? I did this and after 15 minutes I stopped because it did not work.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. KamilPRO

    KamilPRO Member

    Joined:
    Sep 24, 2006
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    151
    log1
    Code:
    [Mon Jul 23 05:34:56 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/kondzi.xyz.pl.
    [Mon Jul 23 05:48:54 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 05:48:54 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/katalog.xyz.pl.
    [Mon Jul 23 05:50:41 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 05:50:41 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/onus.xyz.pl.
    [Mon Jul 23 05:50:43 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 05:50:43 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/onus.xyz.pl.
    [Mon Jul 23 05:54:43 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 05:54:43 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/ksy.xyz.pl.
    [Mon Jul 23 05:57:17 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 05:57:18 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/piszczu.xyz.pl.
    [Mon Jul 23 06:04:59 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 06:04:59 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/kmtychy.xyz.pl.
    [Mon Jul 23 06:05:41 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 06:05:41 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/konopielka.xyz.pl.
    [Mon Jul 23 06:08:27 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 06:08:27 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/konopielka.xyz.pl.
    [Mon Jul 23 06:12:20 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 06:12:20 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/konopielka.xyz.pl.
    [Mon Jul 23 06:14:05 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 06:14:05 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/kozienice-sport.xyz$
    [Mon Jul 23 06:16:05 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 06:16:05 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/kudzik.xyz.pl.
    [Mon Jul 23 06:16:39 2007] [notice] mod_security/1.9.1 configured
    [Mon Jul 23 06:16:39 2007] [error] (12)Cannot allocate memory: could not open transfer log file /usr/local/apache/domlogs/kulturysci.xyz.pl.
    log2
    Code:
    62.147.177.115 - - [23/Jul/2007:01:25:19 +0200] "GET /phpbb2/index.php HTTP/1.0" 404 -
    62.147.177.115 - - [23/Jul/2007:01:25:27 +0200] "GET /forums/index.php HTTP/1.0" 404 -
    62.147.177.115 - - [23/Jul/2007:01:25:32 +0200] "GET /board/index.php HTTP/1.0" 404 -
    127.0.0.1 - - [23/Jul/2007:01:26:39 +0200] "GET / HTTP/1.0" 200 2860
    74.6.27.119 - - [23/Jul/2007:01:28:06 +0200] "GET /robots.txt HTTP/1.0" 404 -
    74.6.22.234 - - [23/Jul/2007:01:28:06 +0200] "GET /viewforum.php?f=7 HTTP/1.0" 403 -
    66.249.67.174 - - [23/Jul/2007:01:29:39 +0200] "GET /viewtopic.php?p=244&sid=32040346910fba4d8b4b53c880d4af06 HTTP/1.1" 403 -
    127.0.0.1 - - [23/Jul/2007:01:30:02 +0200] "GET /whm-server-status HTTP/1.0" 200 11595
    66.249.67.174 - - [23/Jul/2007:01:31:05 +0200] "GET /viewtopic.php?t=101&start=0&postdays=0&postorder=asc&highlight=&sid=6928c5fab8e607748b59$
    66.249.67.174 - - [23/Jul/2007:01:31:07 +0200] "GET /viewtopic.php?p=245&sid=53f37c0b214dadb7a18329d0e7e0900f HTTP/1.1" 403 -
    127.0.0.1 - - [23/Jul/2007:01:32:27 +0200] "GET / HTTP/1.0" 200 2860
    127.0.0.1 - - [23/Jul/2007:01:35:01 +0200] "GET /whm-server-status HTTP/1.0" 200 11717
    66.249.67.174 - - [23/Jul/2007:01:36:53 +0200] "GET /robots.txt HTTP/1.1" 404 -
    66.249.67.174 - - [23/Jul/2007:01:36:53 +0200] "GET /css/template_css.css HTTP/1.1" 404 -
    127.0.0.1 - - [23/Jul/2007:01:40:01 +0200] "GET /whm-server-status HTTP/1.0" 200 12204
    65.55.209.196 - - [23/Jul/2007:01:40:05 +0200] "GET /robots.txt HTTP/1.0" 404 -
    65.55.209.196 - - [23/Jul/2007:01:40:05 +0200] "GET /posting.php?mode=quote&p=161&sid=6e0d915b6737568a12b2f55042bf6109 HTTP/1.0" 403 -
    127.0.0.1 - - [23/Jul/2007:01:40:50 +0200] "GET / HTTP/1.0" 200 2860
    127.0.0.1 - - [23/Jul/2007:01:45:01 +0200] "GET /whm-server-status HTTP/1.0" 200 12245
    216.168.253.195 - - [23/Jul/2007:01:47:03 +0200] "\x80@\x01\x03" 501 -
    216.168.253.195 - - [23/Jul/2007:01:47:03 +0200] "\x80@\x01\x03" 501 -
    216.168.253.193 - - [23/Jul/2007:01:47:13 +0200] "\x80@\x01\x03" 501 -
    216.168.253.193 - - [23/Jul/2007:01:47:14 +0200] "\x80@\x01\x03" 501 -
    127.0.0.1 - - [23/Jul/2007:01:49:12 +0200] "GET / HTTP/1.0" 200 2860
    127.0.0.1 - - [23/Jul/2007:01:50:01 +0200] "GET /whm-server-status HTTP/1.0" 200 12322
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. KamilPRO

    KamilPRO Member

    Joined:
    Sep 24, 2006
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    151
    Code:
    [root@serwer 72]# /scripts/easyapache
    Fetching http://layer1.cpanel.net/buildapache.sea (0)....@69.90.250.34......connected......receiving...1%...2%...3%...4%...5%...6%...7%...8%...9%...10%...11%...12%...13%...14%...15%...16%...17%...18%...19%...20%...21%...22%...23%...24%...25%...26%...27%...28%...29%...30%...31%...32%...33%...34%...35%...36%...37%...38%...39%...40%...41%...42%...43%...44%...45%...46%...47%...48%...49%...50%...51%...52%...53%...54%...55%...56%...57%...58%...59%...60%...61%...62%...63%...64%...65%...66%...67%...68%...69%...70%...71%...72%...73%...74%...75%...76%...77%...78%...79%...80%...81%...82%...83%...84%...85%...86%...87%...88%...89%...90%...91%...92%...93%...94%...95%...96%...97%...98%...99%...100%......Done
    Creating directory buildapache
    Verifying archive integrity... All good.
    Uncompressing buildapache.......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
    Checking Update System........[B][COLOR="Red"]Your operating system's rpm update method (yum) was not able to locate the glibc package. This is an indication of an improper setup. You must correct this error before you can proceed.[/COLOR][/B]Please correct the conflicts and try again!
    initfpsuexec: using apache 1.x support
    Waiting for httpd to restart..........httpd: no process killed
    ....finished.
    
    
    httpd has failed, please contact the sysadmin.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,131
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    New York
    Well from log1 :

    [error] (12)Cannot allocate memory

    So did anything change on the machine?. Is anything gobbling up ram on the box right now?. When was the last time you booted the box ?


    The log2 shows no data since 1am or so on jul 23 so I guess its been down or just didnt post anything since.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice