majdi

Member
Nov 4, 2007
8
0
51
Hello,

I have upgraded php from 4.4.7 to 5.2.4 using WHM Apache update. the process completed successfully, however, now i cannot run any php file!!!! i get a file open window in my browser:you have chosen to open a file which is application/x-http-php. can you please help ASAP!!!
 

majdi

Member
Nov 4, 2007
8
0
51
I fixed the problem by uncommenting the following lines in httpd.com

LoadModule php4_module libexec/libphp4.so
AddModule mod_php4.c


however, i'm still running php4!!!!

any help in upgrading to php5???
i used to Apache Update Under software update in WHM and checked php 5.2.4? any other way to upgrade to php5???
 
Last edited:

jayh38

Well-Known Member
Mar 3, 2006
1,213
0
166
What build of easy apache and cpanel are you using?

Did you try running updates prior to building as recommended?
 

majdi

Member
Nov 4, 2007
8
0
51
I have the following versions:

WHM 11.2.0 cPanel 11.11.0-S18033
REDHAT Enterprise 4 i686 on standard - WHM X v3.1.0

Apache/1.3.39 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.4.7 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.30 OpenSSL/0.9.7a

No, i did not run updates, just used the Apache update under software updates
 

jayh38

Well-Known Member
Mar 3, 2006
1,213
0
166
Thats the latest stable build.

I would try running
/scripts/upcp --force or in whm > cpanel > upgrade to latest version

and tick the "force reinstall" box then try a php upgrade.

It will provide you the location of the build log so you can refer to it for errors.
 

majdi

Member
Nov 4, 2007
8
0
51
Thanks, it worked!
i had to update CPanel first then install PHP5. However, mysql was not enabled until i installed MySQL DEVEL package and re-complied phh5 again