The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache problems

Discussion in 'Workarounds and Optimization' started by martynh, Jan 26, 2010.

  1. martynh

    martynh Active Member

    Joined:
    Oct 6, 2009
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    Im not sure what has caused this because a few things have been to the server in the last few days, we have edited the apache config settings but have moved them back to the originals, we have moved over 80 accounts to the server too but the daily cpu usage shows nothing high...

    In "top" we see the following:

    11551 nobody 18 0 142m 123m 2976 S 78.8 3.1 0:05.61 httpd

    with many many more of them with high loads like above constantly....

    The following is what a website suggested I do:

    root@eco [~]# ps u -C httpd
    USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
    root 8164 0.6 3.0 145452 127276 ? Ss Jan26 0:27 /usr/local/apache/bin/httpd -k start -DSSL
    root 9083 0.0 3.0 145448 124176 ? S 00:35 0:00 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 9086 0.8 3.0 145928 126984 ? S 00:35 0:03 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 9089 1.8 3.0 146608 127464 ? S 00:35 0:07 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 9551 0.7 3.0 146056 126948 ? S 00:36 0:02 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 9577 1.9 3.0 146632 127704 ? S 00:37 0:06 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 10197 1.6 3.0 146556 127516 ? S 00:39 0:03 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 10201 2.9 3.0 146536 127424 ? S 00:39 0:06 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 10202 1.6 3.0 146536 127532 ? S 00:39 0:03 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 10902 1.7 3.0 145984 126316 ? S 00:40 0:02 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 10904 0.5 3.0 145856 126232 ? S 00:40 0:00 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 10905 0.6 3.0 145828 126684 ? S 00:40 0:00 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 11443 1.4 3.0 145720 125932 ? S 00:42 0:00 /usr/local/apache/bin/httpd -k start -DSSL
    nobody 11444 1.6 3.0 145720 125936 ? S 00:42 0:00 /usr/local/apache/bin/httpd -k start -DSSL

    All we see in the CPU usage in WHM is many:

    /usr/local/apache/bin/httpd -k start -DSSL


    We are using a CENTOS 5.4, Core 2 Quad core, 4 GB RAM, apache 2.2.14, SuPHP, Mod_security


    We have removed all the mod_security config like someone else suggested in another topid but this made no difference, we have many many changes to the config files including changing of memory limits but it seems to make no difference.

    Its only started happening for the last few days and wondered if anyone has any suggested we can try to resolved this


    If you do need anymore information to work with please do let me know

    thanks
    martyn
     
  2. mirceacr

    mirceacr Member

    Joined:
    Jan 12, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    help ..apache configuration, websites running slow

    Hi,

    I have one major issue, I get lots of compalins from visitators of different sites hosted on this server claiming sites running slow or quite not displaying.

    I have upgraded this 3 weeks ago, the hardware is quite performant, Load Average is excelent, moemory, only 120 sites hosted on this server, no high bandwidth utilisation ...effectively I do not see effective reason in regard the utilisation.
    I have also adjusted the Apache parameters and have tried to change the settings in order to get best optimisations. I have no other choices.
    I have set statistics time not to start at the respective hours, I have configured Apache to log minimum ....etc

    An important observation is that the time response becomes critical(50 seconds) starting by 7 AM CST (14.00 server time) and takes couple of hours 2 PM CST (20 PM server time). Out of these hours, it works excelent.



    Server Version: Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.12 mod_perl/2.0.4 Perl/v5.8.8
    Server Built: Jan 19 2010 01:26:37

    The values are:

    maxrequestsperchild 600
    startservers 800
    servertokens Minimal
    traceenable Off
    fileetag None
    root_options ExecCGI FollowSymLinks Includes IncludesNOEXEC Indexes MultiViews SymLinksIfOwnerMatch
    sslciphersuite ALL:!ADH:+HIGH:+MEDIUM:-LOW:-SSLv2:-EXP
    serversignature Off
    minspareservers 200
    maxclients 256
    maxspareservers 800
     
  3. Kurieuo

    Kurieuo Well-Known Member

    Joined:
    Dec 13, 2002
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    I just upgraded to the most recent cPanel version and I am having the same thing. Higher server loads, lots of nobody httpd processes, and have an identical setup to yourself with CentOS 5.4, suPHP, Apache, etc.

    Not sure what is going on... going to wait a day or so see if it settles. Please let me know if you resolve it.
     
  4. martynh

    martynh Active Member

    Joined:
    Oct 6, 2009
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    Well I can confirm its definitely software related and nothing to do with hardware or amount of accounts... Due to some other problems with our server I backed up all accounts and reinstalled the OS, I re-setup up the server how it was and then restored all the accounts again, I'm running smoothly now.

    Thats tells me its only a setting and can be resolved if someone can pinpoint what the problem is.

    Martyn
     
  5. Kurieuo

    Kurieuo Well-Known Member

    Joined:
    Dec 13, 2002
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    Glad to hear you fixed it. I don't have the luxury to be able to re-setup the server, and server loads seem to be progressively worsening.

    I've submitted a support request to see if any known issues, but otherwise I might rebuild Apache to see if that does the trick.
     
  6. martynh

    martynh Active Member

    Joined:
    Oct 6, 2009
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    Yeah I think rebuilding apache is worth a try if its getting worse, atleast you will also be able to update everything in the process.

    Martyn
     
  7. Kurieuo

    Kurieuo Well-Known Member

    Joined:
    Dec 13, 2002
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    Did the rebuild, and went a bit lower but server load still higher than usual. :(

    Just wondering, do you still get a lot of nobody httpd processes?
     
  8. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    What is your ticket ID number of the support request that was submitted?

    It is normal for Apache/httpd to run as user nobody.
     
  9. martynh

    martynh Active Member

    Joined:
    Oct 6, 2009
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    Yeah you will always have many of them in the processor list but when they start hitting very high CPU loads is when you want to worry... At first I was not sure this was normal to see them in the process list I think thats because I never really noticed them until I got the high loads... I had the exact same problem where it start off very low and got worse every day until one day I saw in the daily process log that it was hitting 130% + all the time.

    Would like to know what it is though once you resolve it

    Martyn
     
  10. Kurieuo

    Kurieuo Well-Known Member

    Joined:
    Dec 13, 2002
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    Ticket ID was #569042.

    I am beginning to see some lower server loads (< 1), however still get out of the ordinary spikes (> 10).

    I originally had the spareservers etc set in the pre-main include: /usr/local/apache/conf/includes/pre_main_2.conf. However, cPanel also has some of these settings in the global configuration which gets compiled in the httpd.conf itself. I updated both to be the same.

    Might be just a matter of tweaking some Apache settings. The higher server loads don't ground my server to a halt, but they are definitely more noticible when compared to before I updated cPanel recently.
     
  11. asiams

    asiams Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hokkaido, JAPAN
    Maybe eAcellerator problem?

    Hi,

    Are you using eacellerator? This can be a cause for the problem. If the version is 0.9.6, it can be the casue. Disable it or downgrade it.

    Hope this can be a help.
     
Loading...

Share This Page