The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache problems

Discussion in 'EasyApache' started by cka, Jul 7, 2004.

  1. cka

    cka Member

    Joined:
    May 19, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi, on my cPanel webserver apache is being incredibly subborn. For most of today, it simply wouldn't start at all, or would start and stay alive for 30 seconds then die again (and the odd time it would dump a SIGTERM error into the error_log.) Now it's moaning about modules after I ran buildapache via the WHM, as such:

    root@main [/usr/local/apache/conf]# service httpd start
    Syntax error on line 221 of /usr/local/apache/conf/httpd.conf:
    Cannot add module via name 'mod_env.c': not in list of loaded modules
    /etc/init.d/httpd start: httpd could not be started
    root@main [/usr/local/apache/conf]#

    Can anybody help me out with this? I'm at my wits end.
     
  2. cka

    cka Member

    Joined:
    May 19, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    update:

    I got it working by recompiling apache and php (for the 4th time today), but now my sites are insanely slow, despite a low load average on the server and fairly good traceroutes... Anybody know a remedy for THAT?


    edit: nevermind, I -9'd portsentry and apparently everything is working okay now.
     
    #2 cka, Jul 7, 2004
    Last edited: Jul 7, 2004
  3. cka

    cka Member

    Joined:
    May 19, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    aaaaaaaaaand the problems are back, but this time I'm seeing some relevant info. Seems that cpanel itself is killing off httpd, and trying to restart it, when it times out after checking /scripts/checkmaxclients. But I'm positive it's hitting nowhere near that number.

    edit: what chkservd.log is showing:

    And it essentially repeats like that.
     
    #3 cka, Jul 7, 2004
    Last edited: Jul 7, 2004
  4. Sinewy

    Sinewy Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    whm's easyapache = pain in the backside and uses more bandwidth on your internet connection.

    i suggest you run /scripts/easyapache and choose option 1. then when that completes, run it again with option 5.

    It is much much better and faster via SSH compared to WHM.
     
  5. cka

    cka Member

    Joined:
    May 19, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Yeah, I ran easyapache a couple of times and it didn't fix my problems. Turns out the server was getting a bad DDoS attack that was locking any new apache connections. It's fixed now. :cool:
     
Loading...

Share This Page