The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Process Running as Root?

Discussion in 'EasyApache' started by nickp666, Jan 24, 2006.

  1. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    Hey Guys,

    Got a strange one here, seems as if one of my apache processes is running as root, even after a restart of apache this morning it is there, is there a particular reason for this? is it not a security risk?

    the specific line after ps -A -F:
     
  2. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    found why - WHM apache restarter spawns a root process, is this a bug?
     
  3. NT

    NT Well-Known Member

    Joined:
    May 4, 2004
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England, UK
    I think Apache is initially run as root and then spawns children with the Apache user.

    Hope that helps.
     
  4. dropby23

    dropby23 Well-Known Member

    Joined:
    Jan 16, 2005
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    that is right mani process starts under root
     
Loading...

Share This Page