The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache recompile wont work :(

Discussion in 'EasyApache' started by I-Web, Jan 10, 2004.

  1. I-Web

    I-Web Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Im trying to recompile apache, i have tried the link in whm and /scripts/easyapache

    It goes through the whole process, doesnt come up with any errors, but it just doesnt change the compile :(

    even if i select option 1 from easyapache it doesnt change the ./configure line in my phpinfo

    Anyone got any ideas???

    Running latest release version
     
  2. comprock

    comprock Member

    Joined:
    Nov 6, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I'm having pretty much the same issue. Easyapache and WHM don't error out, but I still don't get PHP 4.3.4. I do have Zend installed. Does that make a difference?

    Thoughts?

    Thanks,

    Michael
     
  3. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Been complaining about this for two weeks now with no resolve or response from Cpanel developers. This is getting a little bit old at this point.
     
  4. comprock

    comprock Member

    Joined:
    Nov 6, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    You're right. Searching for buildapache, easyapache, apache compile returns mixed results. I've even had my box manager take a look and he didn't error either, but nor did the new stuff get installed.

    Michael
     
  5. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Since we have been waiting for an easyapache fix for quite some time now with zero response from Cpanel I started running a few tests. We finally got php 4.3.4 to compile by selecting it as the only custom option and letting it compile. We were then able to add GD, Gettext, Freetype and dom by selecting those options in the next compile and selecting 4.3.4 as the only php option. After that compile was done we selected the same options and then Curl, Curl+ssl, Imap and Mcrypt. This added the original options and Curl and Imap. The other two still failed. We at least have a half configured Apache now, but additional compiles adding extra features have proven to be useless.

    Please one of you developers take some time and get this fixed correctly.
     
  6. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    I've heard that taking out the PSPELL option when compiling helps.
     
  7. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Yea, saw that too but it is useless. I have run the compile as simple as PHP 4.3.4, Curl, Curl+SSL, GD, Gettext, IMAP, Mcrypt and Freetype and all that gets put in is curl, gd, gettext and freetype. I have not found any variation of selections that will add IMAP and Mcrypt.
     
Loading...

Share This Page