The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Restart Problem

Discussion in 'EasyApache' started by sparek-3, Apr 4, 2007.

  1. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    I am having problems with Apache dying on one of our servers. The error log is showing:

    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_off: Invalid argument
    accept_mutex_on: Invalid argument
    accept_mutex_on: Invalid argument
    accept_mutex_on: Invalid argument
    accept_mutex_on: Invalid argument
    accept_mutex_on: Invalid argument


    Right before Apache appears to die and is restarted.

    I don't know if this has anything to do with Apache dying or if it is just random chance. Does anyone have any idea where to look for the possible problem?

    I did find one thread concerning this at:

    http://forums.cpanel.net/showthread.php?t=35002

    However that thread is a few years old, and I did try clearing out the logs, but that did not seem to help. I'm just looking for any clues regarding this.

    Thanks
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    It could be a Php Module not working properly. Did you rebuild Apche? Any errors during the rebuild?
     
  3. Sash

    Sash Well-Known Member

    Joined:
    Feb 18, 2003
    Messages:
    252
    Likes Received:
    0
    Trophy Points:
    16
    Were you able to resolve the problem? We're having this same issue on one of our other servers.

    Here is the error that is produced in the error log:

    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_off: Invalid argument
    [Wed Jul 25 16:13:19 2007] [alert] Child 28130 returned a Fatal error... \nApache is exiting!

    We recompiled Apache without any problems, but the issue still occurs.

    Thanks,
    Mike
     
Loading...

Share This Page