The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Restarting

Discussion in 'EasyApache' started by mehrana, Jan 14, 2013.

  1. mehrana

    mehrana Registered

    Joined:
    Jan 14, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I have the same problme in a new instalation,

    I see this in error log:
    Graceful restart requested, doing restart

    server goes away for 5 min and all the site stop working,
    after that again start working, also I didn't find any exact time fro restart, it's random

    Help Please.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I moved this response into it's own thread because it was posted to an unrelated discussion. Graceful restarts for Apache are normal every 2 hours and every 24 hours due to the default statistics processing intervals. You can see this by running a command such as:

    Code:
    # grep "Graceful restart" /usr/local/apache/logs/error_log
    However, it should not take five minutes for your websites to begin loading after a graceful restart of Apache. Do you notice the same behavior when you restart Apache manually?

    Thank you.
     
  3. hgrg

    hgrg Well-Known Member

    Joined:
    Oct 4, 2010
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    i think that means a server reboot not a server restarting..
     
  4. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Well you are wrong.

    When I execute command:
    Code:
    /etc/rc.d/init.d/httpd -k graceful
    
    I see this in /usr/local/apache/logs/error_log
    Code:
    [Tue Jan 15 04:53:42 2013] [notice] Graceful restart requested, doing restart
    [Tue Jan 15 04:53:42 2013] [notice] SSL FIPS mode disabled
    [Tue Jan 15 04:53:42 2013] [notice] Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations
    
    
     
Loading...

Share This Page