The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache restarts every 3-4 hours

Discussion in 'EasyApache' started by Malik, Jan 27, 2005.

  1. Malik

    Malik Member

    Joined:
    Dec 16, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    apache restarts every 3-4 hours
    error_log:
    ----------------------------
    [Thu Jan 27 18:08:57 2005] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Jan 27 18:08:59 2005] [notice] SIGUSR1 received. Doing graceful restart
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_off: Invalid argument
    accept_mutex_on: Identifier removed
    [Thu Jan 27 18:09:00 2005] [notice] Apache/1.3.33 (Unix) PHP/4.3.10 mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_ssl/2.8.22 OpenSSL/0.9.7e configured -- resuming normal operations
    [Thu Jan 27 18:09:00 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Thu Jan 27 18:09:00 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Thu Jan 27 18:09:00 2005] [alert] Child 15067 returned a Fatal error... \nApache is exiting!
    [Thu Jan 27 18:15:04 2005] [notice] Apache/1.3.33 (Unix) PHP/4.3.10 mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations
    [Thu Jan 27 18:15:04 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Thu Jan 27 18:15:04 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Thu Jan 27 18:15:04 2005] [error] [client 83.113.166.60] File does not exist: /home/gamez/public_html/favicon.ico
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Such problems seem to be commonly cause by excessively large log files. What are the size of your apache logs in:

    /etc/httpd/logs/*

    If they're large, rotate them.
     
  3. Malik

    Malik Member

    Joined:
    Dec 16, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Not helped it.
     
  4. Sash

    Sash Well-Known Member

    Joined:
    Feb 18, 2003
    Messages:
    252
    Likes Received:
    0
    Trophy Points:
    16
    Were you able to resolve the problem? We're having this same issue on one of our other servers.

    Here is the error that is produced in the error log:

    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_on: Identifier removed
    accept_mutex_off: Invalid argument
    [Wed Jul 25 16:13:19 2007] [alert] Child 28130 returned a Fatal error... \nApache is exiting!

    We recompiled Apache without any problems, but the issue still occurs.

    Thanks,
    Mike
     
  5. thealee

    thealee Member

    Joined:
    Oct 5, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Did anyone get a fix to this? I'm getting this on a box, and its VERY annoying!
     
  6. Sash

    Sash Well-Known Member

    Joined:
    Feb 18, 2003
    Messages:
    252
    Likes Received:
    0
    Trophy Points:
    16
    Recompiling Apache/PHP fixed the problem for us.

    Thanks,
    Mike
     
  7. switzine

    switzine Member

    Joined:
    Jul 9, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    This issue can happen if you are not removing the semaphore arrays properly. :)

    Are you using any scripts for removing semaphore arrays in the server?

    If so, please check the script and correct it.;)

    Chears!
    Switzine J.
    Switzine@gmail.com
     
Loading...

Share This Page