Takumi80

Member
Nov 7, 2015
17
0
1
Milan
cPanel Access Level
Root Administrator
Hello,
i have apache server down
when i restart after many seconds i receive this error:

Cpanel::Exception::Timeout/(XID f4r2v6) The system failed to lock the file “/etc/apache2/conf/httpd.conf” after 121 seconds. at /usr/local/cpanel/Cpanel/Exception/CORE.pm line 336. Cpanel::Exception::create("Timeout", "The system failed to lock the file \x{e2}\x{80}\x{9c}[_1]\x{e2}\x{80}\x{9d} after [quant,_2"..., ARRAY(0xfef328)) called at /usr/local/cpanel/Cpanel/Exception.pm line 46 Cpanel::Exception::__ANON__(__CPANEL_HIDDEN__, __CPANEL_HIDDEN__..., ARRAY(0xfef328)) called at /usr/local/cpanel/Cpanel/SafeFile.pm line 710 Cpanel::SafeFile::_timeout_exception("/etc/apache2/conf/httpd.conf", 121) called at /usr/local/cpanel/Cpanel/SafeFile.pm line 742 Cpanel::SafeFile::_die_if_file_is_flocked_cuz_already_waited_a_while("/etc/apache2/conf/httpd.conf", 121) called at /usr/local/cpanel/Cpanel/SafeFile.pm line 811 Cpanel::SafeFile::_lock_wait("/etc/apache2/conf/httpd.conf") called at /usr/local/cpanel/Cpanel/SafeFile.pm line 339 Cpanel::SafeFile::_safelock("/etc/apache2/conf/httpd.conf") called at /usr/local/cpanel/Cpanel/SafeFile.pm line 538 Cpanel::SafeFile::_safe_open(GLOB(0x833d38), "<", "/etc/apache2/conf/httpd.conf", CODE(0x860c60), "safeopen") called at /usr/local/cpanel/Cpanel/SafeFile.pm line 107 Cpanel::SafeFile::safeopen(GLOB(0x833d38), "<", "/etc/apache2/conf/httpd.conf") called at /usr/local/cpanel/Cpanel/HttpUtils/ApRestart.pm line 107 Cpanel::HttpUtils::ApRestart::safeaprestart(1) called at bin/safeapacherestart.pl line 27
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
Hello,

Do you notice any error messages when rebuilding the Apache configuration file? EX:

Code:
/scripts/rebuildhttpdconf
If not, can you verify if you are using any third party web server applications (e.g. Litespeed, Nginx)?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
Its true i have tried after restarting and it worked.
Hello,

Do you know if this happened after performing a specific action or if the server load was high? Can you let us know which version of cPanel & WHM is installed on the system, and if you are using CloudLinux and/or LiteSpeed?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
New We are using version v68.0.37 of cPanel & WHM.
Are using CloudLinux and/or LiteSpeed? Do you know if this happened after performing a specific action or if the server load was high?

Thank you.