Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Apache Service won't start

Discussion in 'EasyApache' started by Rodrigo Gomes, Jan 17, 2017.

  1. Rodrigo Gomes

    Rodrigo Gomes Well-Known Member

    Joined:
    Apr 6, 2016
    Messages:
    88
    Likes Received:
    21
    Trophy Points:
    8
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    The Apache service is not starting with the boot.
    No warning message appears in the logs, apache just does not start. But when I start manually, everything works normally.

    Another strange thing is that in the Service Status "httpd" appears Ok.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you notice any error output related to Apache in the /var/log/boot.log log file?

    Thank you.
     
    Rodrigo Gomes likes this.
  3. Rodrigo Gomes

    Rodrigo Gomes Well-Known Member

    Joined:
    Apr 6, 2016
    Messages:
    88
    Likes Received:
    21
    Trophy Points:
    8
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    Seems I found something: pastebin.com/eLsrwMCP

    Code:
    [[1;31mFAILED[0m] Failed to start mailman services.
    See 'systemctl status mailman.service' for details.
    [[32m  OK  [0m] Started cPanel Queue services.
    [[1;31mFAILED[0m] Failed to start Apache webserver managed by cPanel EasyApache.
    See 'systemctl status httpd.service' for details.
    Code:
    [~]# systemctl status mailman.service -l
    ● mailman.service - mailman services
       Loaded: loaded (/etc/systemd/system/mailman.service; enabled; vendor preset: disabled)
       Active: failed (Result: resources) since Qui 2017-01-19 16:27:19 BRST; 49s ago
    
    Jan 19 16:27:18 server-host systemd[1]: Starting mailman services...
    Jan 19 16:27:19 server-host restartsrv_mailman[727]: (XID mhpanz) O serviço “mailman” não está configurado: there are no configured mailing lists
    Jan 19 16:27:19 server-host restartsrv_mailman[727]: The “mailman” service is not configured: there are no configured mailing lists
    Jan 19 16:27:19 server-host systemd[1]: PID file /usr/local/cpanel/3rdparty/mailman/data/master-qrunner.pid not readable (yet?) after start.
    Jan 19 16:27:19 server-host systemd[1]: Failed to start mailman services.
    Jan 19 16:27:19 server-host systemd[1]: Unit mailman.service entered failed state.
    Jan 19 16:27:19 server-host systemd[1]: mailman.service failed.
    
    Code:
    [~]# systemctl status httpd.service -l
    ● httpd.service - Apache webserver managed by cPanel EasyApache
       Loaded: loaded (/etc/systemd/system/httpd.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Qui 2017-01-19 16:27:20 BRST; 55s ago
      Process: 693 ExecStart=/usr/local/cpanel/scripts/restartsrv_httpd --no-verbose (code=exited, status=1/FAILURE)
    
    Jan 19 16:27:18 server-host systemd[1]: Starting Apache webserver managed by cPanel EasyApache...
    Jan 19 16:27:19 server-host restartsrv_httpd[693]: [Thu Jan 19 16:27:19.585128 2017] [so:warn] [pid 1306] AH01574: module reqtimeout_module is already loaded, skipping
    Jan 19 16:27:20 server-host restartsrv_httpd[693]: AH00548: NameVirtualHost has no effect and will be removed in the next release /usr/local/apache/conf/httpd.conf:17038
    Jan 19 16:27:20 server-host restartsrv_httpd[693]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address 123.456.789.182:80
    Jan 19 16:27:20 server-host restartsrv_httpd[693]: no listening sockets available, shutting down
    Jan 19 16:27:20 server-host restartsrv_httpd[693]: AH00015: Unable to open logs
    Jan 19 16:27:20 server-host systemd[1]: httpd.service: control process exited, code=exited status=1
    Jan 19 16:27:20 server-host systemd[1]: Failed to start Apache webserver managed by cPanel EasyApache.
    Jan 19 16:27:20 server-host systemd[1]: Unit httpd.service entered failed state.
    Jan 19 16:27:20 server-host systemd[1]: httpd.service failed.
    But I do not understand why, this ip is idle, and why just at boot?
    And I must worry about the mailman services?

    This is my network config (I hide some info):
    Code:
    TYPE=Ethernet
    BOOTPROTO=none
    DEFROUTE=yes
    IPV4_FAILURE_FATAL=no
    IPV6INIT=no
    IPV6_AUTOCONF=yes
    IPV6_DEFROUTE=yes
    IPV6_FAILURE_FATAL=no
    NAME="Ethernet"
    UUID=5a080ef2-e0cb-49d6-****-f7a0dcd0****
    DEVICE=enp0s3
    NM_CONTROLLED=no
    ONBOOT=yes
    HWADDR=08:00:27:**:**:**
    DNS1=[Removed]
    DNS2=[Removed]
    IPV6_PEERDNS=yes
    IPV6_PEERROUTES=yes
    IPV6_PRIVACY=no
    IPADDR1=123.456.789.179
    PREFIX1=29
    IPADDR2=123.456.789.178
    PREFIX2=29
    IPADDR3=123.456.789.182
    PREFIX3=29
    IPADDR4=123.456.789.181
    PREFIX4=29
    IPADDR=123.456.789.180
    PREFIX=29
    GATEWAY=123.456.789.177
    
     
    #3 Rodrigo Gomes, Jan 19, 2017
    Last edited by a moderator: Mar 15, 2017
  4. Rodrigo Gomes

    Rodrigo Gomes Well-Known Member

    Joined:
    Apr 6, 2016
    Messages:
    88
    Likes Received:
    21
    Trophy Points:
    8
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    I found a problem similar to mine: apache will not start on boot. - CentOS

    But the proposed solution "systemctl enable NetworkManager-wait-online.service" did not work for me because I do not use NetworkManager.

    A few days ago I followed this tutorial to disable the NetworkManager and activate the Network (recommendation of the cpanel installation guide):
    9.3.2. Disabling Network Manager

    And I believe that's when the problem started.
    Is there any other solution I can try?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Rodrigo Gomes likes this.
  6. Rodrigo Gomes

    Rodrigo Gomes Well-Known Member

    Joined:
    Apr 6, 2016
    Messages:
    88
    Likes Received:
    21
    Trophy Points:
    8
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    Hello Michael!
    Because it is a simple problem, I would like to try to solve it on my own and with your help in the forum.

    I'm not in a hurry to resolve this issue.
     
    #6 Rodrigo Gomes, Jan 25, 2017
    Last edited: Jan 25, 2017
  7. Rodrigo Gomes

    Rodrigo Gomes Well-Known Member

    Joined:
    Apr 6, 2016
    Messages:
    88
    Likes Received:
    21
    Trophy Points:
    8
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    I was able to fix this problem by adding: After=network-online.target
    In: /etc/systemd/system/httpd.service

    Code:
    [Unit]
    Description=Apache webserver managed by cPanel EasyApache
    ConditionPathExists=!/etc/httpddisable
    ConditionPathExists=!/etc/apachedisable
    ConditionPathExists=!/etc/httpdisable
    After=network-online.target
    
    [Service]
    Type=forking
    ExecStart=/usr/local/cpanel/scripts/restartsrv_httpd --no-verbose
    
    [Install]
    WantedBy=multi-user.target
    
     
    cPanelMichael likes this.
  8. Bigwebmaster

    Bigwebmaster Active Member

    Joined:
    Dec 3, 2003
    Messages:
    26
    Likes Received:
    8
    Trophy Points:
    153
    I also did something similar to Rodrigo Gomes, my after statement also included ipaliases to make sure each additional IP address was setup too:

    Code:
    After=network-online.target ipaliases.service
     
    Rodrigo Gomes likes this.
Loading...

Share This Page