IonutD

Registered
Nov 17, 2012
4
0
1
cPanel Access Level
Root Administrator
Hello,

My apache server shuts down and doesn't restart back automatically only if i start it using SSH command. The logs when it shuts down are:

Code:
[Fri Nov 30 06:34:38 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:34:38 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:34:38 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:34:48 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:35:22 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:35:23 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:36:00 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:36:00 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:36:01 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:36:02 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:37:07 2012] [emerg] (22)Invalid argument: couldn't grab the accept mutex
[Fri Nov 30 06:53:23 2012] [notice] SSL FIPS mode disabled
[Fri Nov 30 06:53:23 2012] [notice] SSL FIPS mode disabled
[Fri Nov 30 06:53:23 2012] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri Nov 30 06:53:23 2012] [notice] Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.3.15 configured -- resuming normal operations
[Fri Nov 30 06:53:31 2012] [notice] caught SIGTERM, shutting down
[Fri Nov 30 06:53:32 2012] [notice] SSL FIPS mode disabled
[Fri Nov 30 06:53:33 2012] [notice] SSL FIPS mode disabled
[Fri Nov 30 06:53:33 2012] [notice] Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.3.15 configured -- resuming normal operations
Or sometimes just:
Code:
[Thu Nov 29 06:11:52 2012] [notice] Graceful restart requested, doing restart
[Thu Nov 29 06:11:52 2012] [notice] SSL FIPS mode disabled
[Thu Nov 29 06:11:52 2012] [notice] Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.3.15 configured -- resuming normal operations
[Thu Nov 29 07:10:35 2012] [notice] Graceful restart requested, doing restart
[Thu Nov 29 07:10:35 2012] [notice] SSL FIPS mode disabled
[Thu Nov 29 07:10:35 2012] [notice] Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.3.15 configured -- resuming normal operations
[Thu Nov 29 12:26:25 2012] [notice] SSL FIPS mode disabled
[Thu Nov 29 12:26:25 2012] [notice] SSL FIPS mode disabled
[Thu Nov 29 12:26:26 2012] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
 

STS Admin

Well-Known Member
Jul 8, 2012
46
0
56
India
cPanel Access Level
Root Administrator
This type of errors occurs when system is low on memory.

One thing you can try is add the below lines to httpd.conf file
Code:
AcceptMutex fcntl
Also run the distiller to make the changes permanent.
Code:
/usr/local/cpanel/bin/apache_conf_distiller --update
/etc/init.d/httpd restart