BillyS

Well-Known Member
Mar 22, 2013
62
4
58
cPanel Access Level
Root Administrator
I've been watching my CPanel update log files and SpamAssassin has not updated since April 19th. The lines in the file always read the same:

>current version is 1588424, new version is 1588424, skipping channel

The server is set to automatic updates in WHM.

I was told by my hosting company the program version is v3.3.1 and definitions are v3.3.2. Since 1588424 for 3.3.1 is higher than the current version for 3.3.2, SpamAssassin does not update.

Our host also told us instances running the same version of CPanel (11.42.1.16) are doing the same thing. Is anyone else seeing this?

Bill
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello :)

Yes, the output you referenced is normal during cPanel updates. If the primary question is about a new version of SpamAssassin, then yes, there are plans to update SpamAssassin to 3.4.0, but that's currently not scheduled until cPanel version 11.46.

Thank you.
 

BillyS

Well-Known Member
Mar 22, 2013
62
4
58
cPanel Access Level
Root Administrator
The SpamAssassin version in CPanel is v3.3.1

The query for an updated rules refers to v3.3.2

My question is really this...

Are they the same rules / definitions for both versions? The definitions were pretty much updated daily until about a month ago. Now they never update.

Bill
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
You can run the following command to complete the same process that occurs during the cPanel updates:

Code:
/usr/local/cpanel/scripts/sa-update_wrapper
On a test machine, I noticed the following output:

May 23 08:58:32.961 [25214] dbg: generic: SpamAssassin version 3.3.2
This matches the version installed on the system at:

Code:
/usr/local/cpanel/3rdparty/bin/spamd
Where are you seeing that SpamAssassin 3.3.1 is installed on your system? What version of cPanel are you using?

Thank you.
 

BillyS

Well-Known Member
Mar 22, 2013
62
4
58
cPanel Access Level
Root Administrator
When I run
spamassassin -V
I get:
SpamAssassin version 3.3.1
When I run:
/usr/local/cpanel/scripts/sa-update_wrapper
I get:

dbg: generic: SpamAssassin version 3.3.2
SpamAssassin has not updated since April 19th now... CPanel version is 11.42.1.16

Again, I am told by my host this is not unique to my set up. The technician told me SpamAssassin is not updating because the versions are not aligned. He noticed this on several other test machines and was going to check with CPanel. Unfortunately, I noticed this on Saturday morning and the ticket died as it passed from tech to tech.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Are you using a custom/manual installation of SpamAssassin? For instance, you should use this command to check the version:

Code:
/usr/local/cpanel/3rdparty/bin/spamd -V
Thank you.
 

BillyS

Well-Known Member
Mar 22, 2013
62
4
58
cPanel Access Level
Root Administrator
When I run that command I get:
[[email protected] ~]# /usr/local/cpanel/3rdparty/bin/spamd -V
SpamAssassin Server version 3.3.2
running on Perl 5.14.3
May 23 17:37:29.808 [28669] error: Socket version 1.95 required--this is only version 1.94 at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/IO/Socket/SSL.pm line 71.
May 23 17:37:29.808 [28669] error: Can't locate IO/Socket/IP.pm in @INC (@INC contains: /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/5.14.3/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/5.14.3 /opt/cpanel/perl5/514/site_lib/x86_64-linux-64int /opt/cpanel/perl5/514/site_lib) at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/IO/Socket/SSL.pm line 85.
with SSL support (IO::Socket::SSL 1.76)
with zlib support (Compress::Zlib 2.052)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Right, notice the following output:

SpamAssassin Server version 3.3.2
This shows that SpamAssassin version 3.3.2 is included with cPanel. You may want to verify that no other versions of SpamAssassin are installed on your system.

Thank you.
 

storminternet

Well-Known Member
Nov 2, 2011
460
0
66
cPanel Access Level
Root Administrator
Here is the output what I get on our server

[email protected][~]# /usr/local/cpanel/3rdparty/bin/spamd -V
SpamAssassin Server version 3.3.2
running on Perl 5.14.3
Jun 26 16:14:38.492 [1784] error: Socket version 1.95 required--this is only version 1.94 at /usr/local/cpanel/3rdparty/perl/514/lib/perl5/cpanel_lib/IO/Socket/SSL.pm line 71.
Jun 26 16:14:38.498 [1784] error: Can't locate IO/Socket/IP.pm in @INC (@INC contains: /usr/local/cpanel/3rdparty/perl/514/lib/perl5/cpanel_lib/i386-linux-64int /usr/local/cpanel/3rdparty/perl/514/lib/perl5/cpanel_lib /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/514/lib/perl5/5.14.3/i386-linux-64int /usr/local/cpanel/3rdparty/perl/514/lib/perl5/5.14.3 /opt/cpanel/perl5/514/site_lib/i386-linux-64int /opt/cpanel/perl5/514/site_lib) at /usr/local/cpanel/3rdparty/perl/514/lib/perl5/cpanel_lib/IO/Socket/SSL.pm line 85.
with SSL support (IO::Socket::SSL 1.76)
with zlib support (Compress::Zlib 2.052)


Any help is appreciated.
 

storminternet

Well-Known Member
Nov 2, 2011
460
0
66
cPanel Access Level
Root Administrator
Please see the error along with the version

Jun 26 16:14:38.492 [1784] error: Socket version 1.95 required--this is only version 1.94 at /usr/local/cpanel/3rdparty/perl/514/lib/perl5/cpanel_lib/IO/Socket/SSL.pm line 71.
Jun 26 16:14:38.498 [1784] error: Can't locate IO/Socket/IP.pm in @INC (@INC contains:
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
That's just the output when using the -V flag to check the version. It's not an indication of an issue with SpamAssassin.

Thank you.