The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache SpamAssassin with Razor2 and DCC

Discussion in 'EasyApache' started by EDevil, Jun 30, 2004.

  1. EDevil

    EDevil Member

    Joined:
    Feb 17, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Does anyone have a good howto or good instructions on how to install Razor2 and DCC so that SpamAssassin uses them?
    Thanks
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Just install the from source according to their respective installation instructions. If you're running SA through cPanel, restart spamd, if you're running it through MailScanner, restart MailScanner. SpamAssassin should automatically detect that they're installed and start using them. Read the instructions carefully if you use a firewall as you will have to open a port for each product.
     
  3. EDevil

    EDevil Member

    Joined:
    Feb 17, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Okay. I installed razor2 and restarted spamd.

    spamassassin -D --lint shows that Razor2 is found.

    Do we have to create rules that use razor2 and give scores to them?
    Again thanks for the help.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    No, SpamAssassin has inbuilt rules for both Razor and DCC.
     
  5. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    Which inbound port should be open for Razor2?
     
  6. FriedEgg

    FriedEgg Active Member

    Joined:
    Sep 27, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Washington, DC
    Razor needs outgoing access to ports 2703 and 7, although I've never actually seen it use 7.
     
  7. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    OK, thanks for that.
     
  8. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    I did the same .. but is there same way to know if Razor is working ?
    Where can I log monitor Razor ?


    reading this
    http://wiki.apache.org/spamassassin/InstallingRazor

    seems that we need to create a razor accunt .

    Do we need to create it , or spamassassin do all the work itself ?

    thank you
     
  9. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    if I execute

    spamassassin -t -D < 1163586535.H878049P23358.hostname.domain.com

    where 1163586535.H878049P23358.hostname.domain.com is a spam message

    as suggested here
    http://wiki.apache.org/spamassassin/RazorHowToTell

    there is no line about Razor except of this

    [31229] dbg: config: read file /usr/share/spamassassin/25_razor2.cf

    But no line reporting a "Connection established" with razor.


    By the way executing the line above I found that spamassissin to check spamcop.net requires outbound tcp 587 !
     
    #9 Radio_Head, Nov 15, 2006
    Last edited: Nov 15, 2006
  10. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    Hmmm receiving the following via spamassassin -D --lint:


    [32708] warn: config: failed to parse line, skipping: use_razor2 1
    [32708] warn: config: failed to parse line, skipping: razor_config /var/spool/mqueue/.razor/razor-agent.conf
    [32708] warn: config: failed to parse line, skipping: dcc_home /var/dcc
    [32708] warn: config: warning: score set for non-existent rule RAZOR2_CHECK
     
  11. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Did you purchase a license for Razor? If you go to http://wiki.apache.org/spamassassin/InstallingRazor you'll read:

    "Note that Razor is not available for unlimited free use, so it is commented out in init.pre. It is currently free for personal use, subject to capacity constraints. See the Cloudmark SpamNet Service Policy for more details."
     
  12. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    But is that information up to date? ;)

     
  13. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    I got it. They just needed to be updated and then enabled again in v310.pre/v312.pre.
     
  14. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    I installed DCC a few days ago but noticed it is not working in spamassassin.

    Firewall port is open (UDP 6277)

    Ran 'cdcc info' to see if it is installed correctly, then enabled it in v310.pre.

    Did a bit of Googling and found that people add these lines in local.cf

    Tried that, but still no go. Any idea what I'm missing here?

    Saw something about setting DCCIFD_ENABLE to ON in /var/dcc/dcc_conf. Is it necessary to enable this (so it is running as a daemon)?

    Update:
    I noticed these entries in the maillog

    So it was a firewall issue after all. I was using this rule in csf.allow 'udp:eek:ut:d=6277::u=0'. Which is apparently too tight.
     
    #14 jamesbond, Nov 22, 2006
    Last edited by a moderator: Nov 24, 2006
Loading...

Share This Page