The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache & SSI usage

Discussion in 'EasyApache' started by cgimickalo, Oct 2, 2013.

  1. cgimickalo

    cgimickalo Well-Known Member

    Joined:
    Apr 19, 2013
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    N.W. Iowa
    cPanel Access Level:
    Root Administrator
    I just noticed that none of our SSI tags seems to be working any more on our new server. Just switched a couple of weeks ago and they were all working fine on our old server.

    We running Apache/2.2.25 which was the same on our old server.

    Add the "AddHandler server-parsed .html" in the httpd.conf file, restarted httpd still no luck. Tried using the .shtml extension still no luck. The SSI tags that don't work now are:
    Code:
    <!--#include virtual="./LHmenu.html" -->
    <!--#exec cgi="/cgi-bin/ssi_log.cgi" -->
    
    These tags worked perfectly on our other server, running the same apache version. What do I need to change in order for the SSI to work now? I know there was changes in apache 2.4 version w/SSI but were not running that version.

    Ok it does work with the .shtml extension, must have missed that, but can not get it to work the .html extension even after adding the AddHandler server-parsed .html in the httpd.conf file unless I need to change something too.

    Thanks,
    Mike
     
    #1 cgimickalo, Oct 2, 2013
    Last edited: Oct 2, 2013
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you let us know what entries are entered into the .htaccess file within the account? Also, please browse to "WHM Home » Service Configuration » Apache Configuration » Global Configuration" and let us know if "Includes" is enabled under "Directory “/” Options".

    Thank you.
     
  3. cgimickalo

    cgimickalo Well-Known Member

    Joined:
    Apr 19, 2013
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    N.W. Iowa
    cPanel Access Level:
    Root Administrator
    Yes "Includes" is enabled, the .htaccess file is empty.

    I added the "AddHandler server-parsed .html" handler to the httpd.conf, restarted apache, exactly as we did on our other server running the exact same apache version. and it worked fine.

    It does work with the .shtml extension but not with the .html extension. Some of our customers who transferred over where using SSI with the .html extension.

    Mike
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please try adding the following line to the .htaccess file within the account's public_html directory:

    Code:
    AddHandler server-parsed .html 
    Let us know if this makes a difference.

    Thank you.
     
  5. cgimickalo

    cgimickalo Well-Known Member

    Joined:
    Apr 19, 2013
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    N.W. Iowa
    cPanel Access Level:
    Root Administrator
    that seems to do the trick but strangely it didn't seem to work earlier today when I added it to the .htaccess file but now it does ...... hmmmm! Oh well it's ok now. Thanks for your help. ;)

    Mike
     
Loading...

Share This Page