The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache status shows ..reading.. for domains

Discussion in 'EasyApache' started by valkira, Feb 24, 2006.

  1. valkira

    valkira Active Member

    Joined:
    May 3, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Croatia
    cPanel Access Level:
    Root Administrator
    Very strange.... on one our server everything works great, only apache shows ..reading.. for every domain in apache status, and ofcourse, you can't open users web sites...

    (i already try upcp --force and compiling apache+php+all_the_rest)

    And, if i can't open apache status in WHM i get message:
    Unable to retrieve apache status [a fatal error or timeout occurred while processing this directive]
    any idea??
     
    #1 valkira, Feb 24, 2006
    Last edited: Feb 24, 2006
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    BIND/Named is down/corrupted/misconfigured.
     
  3. valkira

    valkira Active Member

    Joined:
    May 3, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Croatia
    cPanel Access Level:
    Root Administrator
    well, i looked up everything about bind, but it seems to be ok...
    i make restore of my conf files, but same problem...
    Bind is runing, resolving, everything ok..on the first view.
    In whm, apache status i cant see domains users want to open, i see only ?
    Something else?
     
  4. kokoman

    kokoman Active Member

    Joined:
    Nov 28, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    BA, Argentina
    The problem is due to a fin_wait2 DoS, to mitigate that you could try lowering the fin_wait state timeout, the kernel options (if your kernel is 2.6) are below,

    net.ipv4.netfilter.ip_conntrack_tcp_timeout_fin_wait = 30
    net.ipv4.tcp_fin_timeout = 30

    to activate these setting, add the lines above to /etc/sysctl.conf, and then write sysctl -p

    To make better the mitigation process, you may reduce the value for 'Timeout' within httpd.conf

    timeout=30 will be ok.
     
Loading...

Share This Page